v10 speedo doesn't work - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel Forum for discussion of the Ford F100, F150, F250, F350, Superduty and Diesel trucks.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-11-10, 02:21 PM Thread Starter
I love 67-72 ford trucks
 
davbell22602's Avatar
 
Join Date: Jan 2009
Location: Winchester,va
Age: 39
Posts: 48
v10 speedo doesn't work

I have a friend who just bought a 2004 F250 V-10 4x4 and the speedometer wont work and overdrive light flashes. he changed a sensor on the back and one on the front and has checked the fuses... not sure where else to go? Any suggestions welcome.

davbell22602 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-11-10, 02:49 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: v10 speedo doesn't work

Have him take it to Autozone to retreive the codes to see what they show.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome