1991 Escort Fuel Gauge not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-25-07, 09:02 PM Thread Starter
Registered User
 
Join Date: Dec 2005
Posts: 14
1991 Escort Fuel Gauge not working

I replaced the fuel pump and gauge assembly and the gauge is still not working. Connections are clean. Any suggestions on what to check next?

Thanks

bkever is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-26-07, 03:00 AM
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 687
Re: 1991 Escort Fuel Gauge not working

Is the temp gauge working ok?
Fordtech. is offline  
post #3 of 4 (permalink) Old 12-06-07, 06:58 PM Thread Starter
Registered User
 
Join Date: Dec 2005
Posts: 14
Re: 1991 Escort Fuel Gauge not working

Temp gauge is working. I notice that the cooling fan is staying on.
bkever is offline  
post #4 of 4 (permalink) Old 02-14-08, 01:30 AM
Registered User
 
Join Date: Nov 2005
Posts: 38
Re: 1991 Escort Fuel Gauge not working

I suggest you check the voltage stabilizer
Hubbes is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome