1998 escort problems???? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-22-05, 10:04 PM Thread Starter
Registered User
 
Join Date: Dec 2004
Age: 36
Posts: 19
1998 escort problems????

Hi there i have a 1998 escort with 129000 miles on it it has never givin me problems at all since new just oil changes and cosmetics.but all of the sudden yesterday i went to start my escort and it sounded like i started a tractor it started missfiring and the whole car was shaking. so my service engine soon light came on and now its not spuddering but i have to litterally make a whole in the floor to reach 80mph. Any help will be apreciated.

reggie4828 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-23-05, 03:33 AM
Registered User
 
Join Date: Oct 2004
Location: Newcastle
Age: 30
Posts: 278
Re: 1998 escort problems????

129 thousand mileS?!?! far out, thats a whole lot of miles! one of my mates has a nissan exa that sounded like a wrx, reason being it had faulty spark plugs and spark leads. yours sounds slightly more serious? id suggest taking it to a mechanic quick smart and not driving it anywhere else!
good luck with it!

Spinning first .... Chirping second ... and NEAAAAARLY chirping third. Fiesta is the word. Its more than just a party on wheels.
Mitch_lx is offline  
post #3 of 5 (permalink) Old 02-23-05, 11:24 PM Thread Starter
Registered User
 
Join Date: Dec 2004
Age: 36
Posts: 19
Re: 1998 escort problems????

hey tahnks a lot i am going to check the electrical system.i wil advise you.
reggie4828 is offline  
post #4 of 5 (permalink) Old 03-25-05, 01:53 PM
Registered User
 
Join Date: Mar 2005
Posts: 2
Re: 1998 escort problems????

I have a 1997 ford escort with the EXACT same problem. I took it to the dealer and paid $80 for diagnostic only to find out it has a bad coil and plug wires.They quoted me an additional $458 to replace I'm replacing them tommorrow for just under $100.
iamford is offline  
post #5 of 5 (permalink) Old 03-25-05, 06:08 PM
Registered User
 
Join Date: Sep 2004
Posts: 144
Re: 1998 escort problems????

hahah dealers tryin to rip ppl off again
barthez is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
98 Escort bad speedo? your opinion please cogsncogs General Tech 1 02-08-05 06:14 AM
Swapping over leaf springs & shockers on a Mk II Escort The MaDDeSTMaN Suspension | Wheels&Tires | Brakes 1 10-27-04 06:04 PM
Escort Idle Problems icenl Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 1 10-05-03 12:45 AM
escort problems Mach1 General Tech 8 09-10-03 02:08 PM
Mk3 Ford Escort Water works! skeggy Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 1 05-03-03 05:51 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome