2000 ZX2 won't stay running - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-30-09, 11:08 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Location: Huntersville, NC
Posts: 4
2000 ZX2 won't stay running

I have a 2000 ZX2 that is showing no codes at all but here is the issue. I can start it up and leave it or drive it and it will be fine. However, once it is warmed up if I come to a stop or park it the RPM drop rapidly and almost instantly it will shut off. But if I am driving it you'd never know anything was wrong. I am used to working on older engines so when I lift the hood on this I am a little lost. Are there any ideas?

Thanks for anything!

TRGBassGuy is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-31-09, 08:06 AM
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: 2000 ZX2 won't stay running

Quote:
Originally Posted by TRGBassGuy View Post
I have a 2000 ZX2 that is showing no codes at all but here is the issue. I can start it up and leave it or drive it and it will be fine. However, once it is warmed up if I come to a stop or park it the RPM drop rapidly and almost instantly it will shut off. But if I am driving it you'd never know anything was wrong. I am used to working on older engines so when I lift the hood on this I am a little lost. Are there any ideas?

Thanks for anything!



Hello and good day:

There could be multiple causes ... IAC (idle arm control valve), MAS (Mass Airflow Sensor) TPS (Throttle Positioning Sensor).

You say there is now CEL (check engine light)??? So it shows not OBDII Codes...

I would start with checking the Air Filter First ... then ... Clean the Throttle Body with a good Throttle Body Cleaner ... you also can use the TBC to clean the MAS But be careful ... use a Cotton Swab ... spray some on it ... and lightly wipe the sensor.

You also can clean the IAC ... but you will need to take this unit off with a 8mm wrench.

Any other info ... please advise.

Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline  
post #3 of 8 (permalink) Old 10-31-09, 11:32 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Location: Huntersville, NC
Posts: 4
Re: 2000 ZX2 won't stay running

There isn't a CEL (I left that part out haha). I will check the air filter. Is there anyway I can test the IAC MAS or TPS? It just doesn't make sense to me why it only does it once it's warmed up. Even if I don't drive it and I let it sit there it will still shut off once it's warm if the accelerator isn't being pressed.
TRGBassGuy is offline  
post #4 of 8 (permalink) Old 11-04-09, 08:06 PM
Registered User
 
Join Date: Jun 2009
Posts: 163
Re: 2000 ZX2 won't stay running

Check for vacuum leaks and it could also be the ignition coil going bad. Coils will usually fail after they get warmed up.
FordMan59 is offline  
post #5 of 8 (permalink) Old 11-07-09, 11:04 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Location: Huntersville, NC
Posts: 4
Re: 2000 ZX2 won't stay running

But if it was a coil would it only fail when idle at a light or stop sign?
TRGBassGuy is offline  
post #6 of 8 (permalink) Old 11-08-09, 06:50 PM
Registered User
 
Join Date: Jun 2009
Posts: 163
Re: 2000 ZX2 won't stay running

Quote:
Originally Posted by TRGBassGuy View Post
But if it was a coil would it only fail when idle at a light or stop sign?
OK, I thought it was all the time once the engine warmed up. My mistake.
FordMan59 is offline  
post #7 of 8 (permalink) Old 11-08-09, 09:21 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Location: Huntersville, NC
Posts: 4
Re: 2000 ZX2 won't stay running

I am sorry if I wasn't clear about that. It will idle fine but once it gets warm that's where the issue is. Now if I am driving you'd never know but when I come to a stop light or sign it will either die right before I come to a complete stop or idle for 2 or 3 seconds then die.
TRGBassGuy is offline  
post #8 of 8 (permalink) Old 11-09-09, 12:09 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 2000 ZX2 won't stay running

Try cleaning the MAF and IAC to see if that helps. There's a special MAF cleaner for the MAF.
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome