5 spd 2001 escort zx2 stalls when slowing or stopping - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-03-09, 08:55 PM Thread Starter
Registered User
 
Join Date: Dec 2009
Posts: 3
confused 5 spd 2001 escort zx2 stalls when slowing or stopping

I've been reading around in a lot of the forum pages to see if I could get this question answered without having to post, but no luck.

Just recently got the Escort as a second car just in case and at first it was running fine, but after a few weeks it started acting up. The engine will completely cut out when I'm slowing down or stopped completely, clutch in or in neutral, engine braking or not, doesn't matter. Starts right back up afterwards and drives normally. My friend who isn't too savvy with cars also has a 2001 Escort ZX2 5spd and also had the same problem, and he said when he got the slave cylinder for the clutch replaced everything was fine. But before I go out shotgunning my chances and buying the cylinder and this and that, I wanted to double check and get some input.

Spark plugs are fine and spark, air filter is new, fuel filter was changed about 4XXX miles ago, basic tune ups all have been done. Fuel pump is relatively new as well. No OBDII codes, no lights popping up, it just gets lazy and wants to take a break at stop signs. Would appreciate the help!

liquidflame802 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-03-09, 09:59 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,344
Re: 5 spd 2001 escort zx2 stalls when slowing or stopping

If it feels like the clutch is releasing, the slave cyl. wouldn't be the problem. I'd start with cleaning the IAC and MAF. There's a special cleaner for the MAF.

Bert
Bert is offline  
post #3 of 4 (permalink) Old 12-04-09, 03:49 PM
Registered User
 
Join Date: Jun 2009
Posts: 163
Re: 5 spd 2001 escort zx2 stalls when slowing or stopping

rtg143 said what I too was thinking. Also check the PCV line for a cracked or split hose that's a pretty common problem with idling issues on the Escorts.
FordMan59 is offline  
post #4 of 4 (permalink) Old 12-05-09, 02:01 PM Thread Starter
Registered User
 
Join Date: Dec 2009
Posts: 3
Re: 5 spd 2001 escort zx2 stalls when slowing or stopping

I'll check those out. The clutch seems fine but I'll check the PCV and the hoses and see if everything is good and give a good cleaning to the MAF and such. Thanks for the help!
liquidflame802 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome