87 Ford Escort running rough and rich - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-27-03, 09:52 AM
techbot
Guest
 
Posts: n/a
87 Ford Escort running rough and rich

I got this little 87 Escort wagon from my brothers to use as a work car. When I'm sitting at a complete stop it runs really rough and you can smell the gas coming from the tailpipe. If I put the car in neutral it'll run smooth, but the smell is still there. Any suggestions? I've been told things such as 02 sensors and/or timing are the causes.

 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-16-03, 11:46 AM
Registered User
 
Join Date: Feb 2003
Location: Eagle Bend, MN
Posts: 270
Re: 87 Ford Escort running rough and rich

It also could be a trans. problems or flywheel?
Vlad_Padberg is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
AU 5.0 running rich fairlane500 Windsor Tech 2 07-12-03 01:53 AM
ea cfi running rich ? rabbi General Tech 3 05-25-03 11:26 PM
FORD FAMILY FIGHTERS: Anne Ford's devotion, not her money and prominence, Stacy94PGT Ford Worldwide News 0 05-14-03 11:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome