91 escort fuel pump issue solved - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-19-12, 10:50 PM Thread Starter
Registered User
 
Join Date: Jul 2007
Posts: 12
91 escort fuel pump issue solved

Are you having trouble figuring out why your escort won't start? Fuel pump not coming on when you turn the key to on position? Well i finally found the problem with my 91 escort and i feel like a genius. Not really but i spent 2 weeks tracing wires, relays, fuses, cleaning corrosion, and reading countless threads from all different sites and finally discovered the problem. Just wanted to share what i found as it seems this could be a big problem that people may overlook. My actual problem was a bad ground at the fuel pump hanger assembly. This is the part that the fuel pump hangs from and where the fuel pump wiring harness connects to the fuel pump. If you pull your back seat there will be a access cover where the fuel pump is located. When removed you will see the where your fuel lines connect and where the fuel pump harness makes contact to the fuel pump itself. You will see 3 hard plastic contacts.(stock ford motorcraft assembly) On your harness the two blue wires turn into 2 black wires and these are ground. The two black/pink wires turn into black and white wires these are positive. The yellow to red is for your sending unit. The brown wire is another ground. The ground(2 black wires) was bad. They were actually corroded inside the black hard plastic coating. I actually dug the coating away with a pocket knife until i found bare metal and the wires just fell off. I soldered them back on and my fuel pump now works. I ordered a new fuel pump assembly anyway. After checking all relays for voltage and jumping the intertia switch i discovered the bad ground. Hope this helps.

rick555 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-20-12, 07:27 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: 91 escort fuel pump issue solved

Good information. Thanks for posting that.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome