92 Escort GT wiper issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-01-12, 09:51 AM Thread Starter
Registered User
 
Join Date: May 2012
Posts: 2
cool 92 Escort GT wiper issues *NEED HELP ASAP*

My windshield wipers quit working the other day on my 92 Escort gt.
The fuses are fine in the fuse box, and the wiper motor has been checked and is ok.
Is there a inline fuse or relay under the hood im not finding?

at first the delay wipers started acting up and not working...then later that day all wiper speeds failed to work.
How common is it for the swtch to go?

My Escort is the 1.8ltr dohc 5speed 2door hatch.


Last edited by bobsure1; 05-01-12 at 04:48 PM. Reason: no replies
bobsure1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-04-12, 05:05 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,804
Re: 92 Escort GT wiper issues

Certainly not uncommon for switch / stalk to fail . Check there is power at motor first .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome