93 Escort 1.9L Fan Won't Run - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-12-2004, 19:04   #1 (permalink)
Charlie Moore
 
Join Date: Nov 2004
Location: Charlottesville, VA
Age: 30
Posts: 1
93 Escort 1.9L Fan Won't Run

Hello,

I have a 93 Escort with 1.9L engine. The radiator fan will not cut on. The fan works (high and low)--I have tested it directly. The main relay (in the fuse block) is good. I can also jump the terminals there and run the fan on low when the ignition is off. Replaced the temperature sensors (both).

Also, I have recently flushed the cooling system out, replaced the thermostat, and pressure tested the system. Nothing has helped so far.

Any suggestions would be greatly appreciated.

Thanks to all, in advance.
__________________
--
Charlie Moore
93 Escort LX Wagon, 210k
KG4BKD is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-07-2004, 18:37   #2 (permalink)
Registered User
 
Join Date: Dec 2004
Age: 28
Posts: 3
Re: 93 Escort 1.9L Fan Won't Run

there are two sensors that are right above the bellhouseing. one is a ect and the other controls the fan. the one on the left will control the fan. good chance it is it. very easy repair.
southerntrax is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
93 Escort 1.9L cooling fan switch? Hectic Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 2 05-21-2004 20:40
'93 Escort problem Freelancer Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 10 05-21-2004 14:45
93 escort transmission johngl Trans | Driveline 0 01-08-2004 09:26
Arrrrghhhhh! laminge The Pub 79 04-11-2003 01:17

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:22.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.