99 ZX2 idle issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-22-2009, 08:55   #1 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 1
99 ZX2 idle issues

I need some help with verification on my 99 ZX2 idle problem. It revs clear up to 2800 rrpm when it first starts and is slow to come back down. It does the same thing when I put it in gear. When driving around 50 mph / 2000 rpm the rpms will drop by 500 rpm by moving the pedal slightly (I mean VERY slightly) and then return.

I unplugged the IAC and the idle retuned to normal, just a little lower. The CEL came on (I haven't taken it down for a code read yet). The high rpm at the start went away, as did the rpm drop while driving. This is how I want it to run, but it will only do it when the IAC is unplugged. I put an ohm meter on the IAC and got 11.5 ohms. Does this mean the IAC is faulty, or is it something else? I removed the IAC and cleaned it. I blew into the chambers, and neither sealed completely. Is this normal or is it leaking? I don't want to buy an expensive part like this unless I know its the problem. The MAF was recently replaced and I've cleaned the throttle body. Neither of these changed the symptoms.
wzdoug is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 16:33.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.