engine missing 93 escort - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-10-2004, 05:34   #1 (permalink)
Registered User
 
Join Date: Jul 2003
Posts: 11
engine missing 93 escort

this car has a series of problems but now i am trying to at least get the thing running correctly again. at idle speed the engine misses but seems to start firing correctly at about 2000 rpm. i did a compression check last night and all cylinders tested at 175 psi. cylinder 1 took a tad bit longer to get there than the others but never the less, it got there. the engine has always been strong but for no reason one day just started idling rough and i haven't been able to figure out the prob. plugs and wires are at most 1 year old, and like i said, passed compression check. any ideas anyone? i'm thinking it's starved of fuel.
Hectic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2004, 17:33   #2 (permalink)
Registered User
 
grey_esp's Avatar
 
Join Date: Sep 2004
Location: W.A.
Posts: 337
Re: engine missing 93 escort

i dont know anything about late model escorts, Injected? Distributor or coil pack?
Assuming its injected and Distributor, Id be checking for play in the distributor, then Id be giving it a service with new plugs, leads, cap, button, fuel filter and air filter and put some injector/fuel system cleaner in the fuel tank. If that doesnt clear it up it could be a vacume leak.
Does it blow any black smoke?
__________________
Pics are post on www.fordespghia.com
grey_esp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford Escort 1.8 Turbo Diesel - Engine Virbration drmshahid Diesel Tech 3 04-27-2005 15:16
MKII escort engine conversions mr_mkII Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 2 07-24-2004 22:12
USA:Cobra engine builders are assembly line stars Stacy94PGT Ford Worldwide News 0 06-22-2004 06:02
engine mount for Ford 94 Escort hansty Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 1 05-05-2004 18:41

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:23.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.