Escort Accelerator Cable Issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-14-2004, 15:53   #1 (permalink)
Registered User
 
eskort's Avatar
 
Join Date: Nov 2003
Location: Sydney
Age: 32
Posts: 10
Escort Accelerator Cable Issues

The accelorator cable on my car keeps slipping off the pedal. I recently replaced it but my borther in law took it off when i was at work and he thinks he lost part of it...ive tried adjusting the tensions and all but people have said you can get clips to hold it on. does anyone have any ideas? Does anyone know where i can get these clips?
eskort is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-15-2004, 01:53   #2 (permalink)
Registered User
 
grey_esp's Avatar
 
Join Date: Sep 2004
Location: W.A.
Posts: 337
Re: Escort Accelerator Cable Issues

You'll have to just go to a wrecker id say mate.
They are similar in principle to the one on the clutch pedal, being spring steel and clipping over the pedal, but from memory the just clip around the rod and stop the little alloy nob on the end of the cable from coming out of the pedal, there by preventing the cable from jumping out, simple but effective.
__________________
Pics are post on www.fordespghia.com
grey_esp is offline   Reply With Quote
Old 12-16-2004, 15:36   #3 (permalink)
Registered User
 
eskort's Avatar
 
Join Date: Nov 2003
Location: Sydney
Age: 32
Posts: 10
Re: Escort Accelerator Cable Issues

thanks! i just wanna drive my car! lol

brooke.
eskort is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel system issues with 86 escort.. SC Fatz V6 and Hot4 Tech 1 07-08-2004 12:32
My Escort is getting closer to being registered... The MaDDeSTMaN The Pub 14 03-16-2004 03:57
1.6L Escort diff in 2.0L Escort (both Mk II Escorts) The MaDDeSTMaN Trans | Driveline 2 11-21-2003 21:42
Escort led Ford's charge back into the sub-compact market Stacy94PGT Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 0 06-19-2003 10:00
Arrrrghhhhh! laminge The Pub 79 04-11-2003 02:17

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:44.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.