Escort Idle Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-03-03, 02:10 PM
Posts: n/a
Escort Idle Problems


I have a '92 Escort GLX and I have some idle problems. First of all the car Idles very unsteady. Lately, when I start the car cold the choke does it work until the engine is warmed up (not completely!) and then the idle problem starts. Sometimes it idles close to stalling and sometimes it's impossible to keep the engine running at a stop. After a while when the engine is completely heated up problems are over (I adjusted the choke well, I think, and seems to work right). The enige runs ok, not steady but good enough. Recently also when the engine is completely heated up it stalls as well at a stop.
I tried some things and this is what I found out:

I noticed oil in the air filter housing coming out of the hose that is connected with the valve cover and connected under the filter housing. While the engine was running idle I closed that hose and suddenly it runned much better. Though today it was a bit worse and the engine stalled again but when heated up it runs fine now. The hose that comes out of the valve cover is connected to a plastic T-piece that connect it to the air filter housing. From that T-piece is a litlle hose running to the intake. So to make thing understandable: The hose from the valve cover is running to a connecting piece of the air filter housing and from there goes a hose to the intake. The hose running from the valve housing is closed now.

Any suggestions what this idle problem I have may be??

Sponsored Links
post #2 of 2 (permalink) Old 10-05-03, 01:45 AM Administrator
Big Block Ford's Avatar
Join Date: Apr 2001
Posts: 4,748
Re: Escort Idle Problems

Is there a valve on the end of the hose where it goes in the valve cover (PCV valve). If so it might be worth replacing it.
Check your choke adjustment by looking in the throat of the carb when it is cold and the choke is set and see that the flap is closed and then check to be sure when it is hot that the choke flap is totally open.
Has anything been done to the car before this problem started.

71 429SCJ Mustang
Big Block Ford is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
EA idle problems defective General Tech 3 06-03-03 06:19 PM
Arrrrghhhhh! laminge The Pub 79 04-11-03 02:17 AM
Mk II Escort Technical Problems EAII^Spack Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 1 07-22-02 01:19 AM
idle problems ea - 6 pete692 General Tech 7 04-17-02 05:46 AM
idle problems rebland Ford Bronco Forum 2 07-24-01 03:47 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome