escort lx trans problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-04-2009, 12:46   #1 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 1
escort lx trans problem

i have a 96 escort lx with the 1.9 liter engine. after i speed up to about 5-10mph the rpms jump up to 3000-4000 and it doesnt go any faster and it sounds like it is shaking at this point. then it smoothly shifts into second(barely feel it at all) and then it drives fine. i called a trans shop and they said it was the vehicle speed sensor and i changed that and the problem still exists. please help
sichko023 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-05-2009, 09:29   #2 (permalink)
Registered User
 
Sterling_Six's Avatar
 
Join Date: Aug 2008
Location: Green Bay, WI
Posts: 1,135
Re: escort lx trans problem

Quote:
Originally Posted by sichko023 View Post
i have a 96 escort lx with the 1.9 liter engine. after i speed up to about 5-10mph the rpms jump up to 3000-4000 and it doesnt go any faster and it sounds like it is shaking at this point. then it smoothly shifts into second(barely feel it at all) and then it drives fine. i called a trans shop and they said it was the vehicle speed sensor and i changed that and the problem still exists. please help




Hello and good day:

Have you ever had a Transmission Flush and Fill?? Or have you ever had a Filter, and Transmission Pan Gasket replaced??
__________________
Good Luck and good repairing Sterling_6
"You know, just like in that Book, When Jesus beats up Moses to get Religion!!"
Sterling_Six is offline   Reply With Quote
Old 10-05-2009, 14:34   #3 (permalink)
Registered User
 
PerformanceX2's Avatar
 
Join Date: Aug 2003
Age: 36
Posts: 25
Re: escort lx trans problem

I had a similar prob with my 97, and it only got worse. Someone tipped my off that it was a problem with a sensor inside the tranny. The engine light is on too, so I read the codes, and found 2: O2 sensor problem (not related) and a code for 'wrong gear 2 ratio'. That makes sense I guess if there's a bad sensor not telling the tranny how to shift correctly.
PerformanceX2 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:38.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.