Escort starting problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-28-07, 01:27 PM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 2
confused Escort starting problem

Hi,

My 1995 RS2000 Escort was broken into last night, the doors were rolled down with crow bars and the steering wheel cover ripped off.

Previously the car started fine, but now it turns over as before but does not start.

I have checked the fuel kill switch, this is pushed in as I think it should be.

Any suggestions on what the problem could be?

Thanks,

Martin.

mja8_uk is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-28-07, 05:55 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: Escort starting problem

You need to find out if it is spark or fuel problem. Check for good spark to all your plugs. Check fuel pressure at the fuel rail. Can you hear your fuel pump come on. (Should be only for a second or two)
thefonz is offline  
post #3 of 5 (permalink) Old 09-01-07, 04:47 PM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 2
Re: Escort starting problem

Cheers for the tips thefonz, luckily today it started fine and seems ok. Just need get the damage sorted from the breakin now.

Thanks again.
mja8_uk is offline  
post #4 of 5 (permalink) Old 09-11-07, 11:44 AM
Registered User
 
Join Date: Sep 2007
Location: norfolk uk
Age: 50
Posts: 3
Re: Escort starting problem

They have most likely damaged the chip sensor around the lock barrel.
tabetha
tabetha is offline  
post #5 of 5 (permalink) Old 09-11-07, 02:50 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: Escort starting problem

Quote:
Originally Posted by tabetha
They have most likely damaged the chip sensor around the lock barrel.
tabetha
Escort doesn't have a chip, especially in 1995 (At least not In the U.S.)
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome