Looking for Assistance. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-20-06, 05:20 AM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 2
Question Looking for Assistance.

I have a 1996 Ford Escort, 1.9L that the fan will not run on the radiator. If I come to a stop and sit idle for a few minutes, the temperature gauge starts to rise. If I start moving again, the gauge will drop.

I have already replaced the thermostat, flushed the radiator, and replaced the fan motor. I checked all teh fuses and they are all working. Someone suggested it may be the relay for the fan, but I cannot find this component anywhere on the engine.

Right above the wheel well on the driver side is a fuse box, but there is no relay for the cooling fan, just the fuel injector.

Does anybody happen to know where the heck this component is located, or what another possible cause of the fan not running may be? Any help would be appreciated. Thanks in Advance.

Chizica

Chizica is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-21-06, 04:59 AM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 2
biggrin Re: Looking for Assistance.

Hey,

Solved my own problem. In the relay block(the fuse box under the hood), there was a relay there. The only problem being was that the cover of the box was labeling it as the Fuel Injector relay. Just out of curiosity, I pulled the relay out and sure enought, two of the contacts were fried. I put the new relay in, and connected the battery.....the fan ran. This may help someone in the future.


Chizica
Chizica is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome