Merkur XR4Ti stalls during heavy acceleration - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-11-2013, 16:50   #1 (permalink)
Registered User
 
Join Date: Dec 2013
Posts: 3
Merkur XR4Ti stalls during heavy acceleration

I'm new here and I think this is the right place for my issue.
I've posted on a Merkur forum but it has a lot less traffic.

I just picked it up the other day and this is the only main mechanical issue with the car.

The car idles good and runs great under low acceleration.
If I floor it, it will shut off.
Basically, if I stay out of boost, it runs fine.
Previous owner thought it may be a plugged cat and was causing too much back pressure. I checked the temps and the outlet of the cat is about 50 degrees F cooler than the inlet. So, it seems to be working.

The exhaust is full 3" with a high flow cat, some sort of glasspack, and then a supertrapp at the end. Not a fan of the supertrapp and planned on removing it and also wonder if that could be causing the back pressure but the car was driven for a few years with that exhaust setup.

I have yet to disconnect the exhaust and drive it to see if that solves the issue. I'm currently waiting for a day when the roads aren't covered in snow to drive it again.

I'm not sure what the issue behind this is so I thought maybe someone on here could help me out.

Thanks
NickGarrison is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-11-2013, 19:07   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,807
Re: Merkur XR4Ti stalls during heavy acceleration

What year and what engine? I'd still check for a plugged exhaust too. What's the vacuum at idler and what does it do when you raise the RPM to 2000RPM and hold it there?
__________________
Bert
Bert is offline   Reply With Quote
Old 12-11-2013, 20:08   #3 (permalink)
Registered User
 
Join Date: Dec 2013
Posts: 3
Re: Merkur XR4Ti stalls during heavy acceleration

1987. turbo 2.3 lima motor
NickGarrison is offline   Reply With Quote
Old 12-11-2013, 21:19   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,807
Re: Merkur XR4Ti stalls during heavy acceleration

What about the vacuum readings?
__________________
Bert
Bert is offline   Reply With Quote
Old 12-11-2013, 21:25   #5 (permalink)
Registered User
 
Join Date: Dec 2013
Posts: 3
Re: Merkur XR4Ti stalls during heavy acceleration

I will have to check tomorrow.
NickGarrison is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 12:16.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.