Oil light still comes on after replacing oil pressure sending unit. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-22-14, 02:33 AM Thread Starter
Registered User
 
Join Date: Mar 2014
Posts: 9
Oil light still comes on after replacing oil pressure sending unit.

I have a 1998 ford escort and already had a bunch of things fixed on it.

Recently the oil light has been coming on but not staying on. It kind of flickers on for a few seconds then goes off. The oil pressure sending unit was leaking so I had that replaced yesterday and figured that took care of the problem.

Tonight the oil light came on again but went right off a couple seconds later.

I heard that it could be the oil pump itself going bad which I hope isn't the case , but are those the only 2 things making the oil light come on?. The oil pump, or oil pressure sending unit?.

If it is the oil pump what would the average cost be to have a mechanic replace it?.


By the way the oil is full and it was changed about 1,000 miles ago.
mash4077 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-22-14, 03:12 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,916
Re: Oil light still comes on after replacing oil pressure sending unit.

Did you change the filter when oil changed ?
R.S.LOGAN is offline  
post #3 of 5 (permalink) Old 05-22-14, 03:31 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,916
Re: Oil light still comes on after replacing oil pressure sending unit.

Depending on mileage , it could be general wear and tear on the engine with bearings etc. that is allowing oil pressure to drop .You could check actual oil pressure with a master gauge to verify . Could even be the oil pump pick up screen partially blocked .

p.s . you dont say what engine fitted .
R.S.LOGAN is offline  
post #4 of 5 (permalink) Old 05-22-14, 03:43 AM Thread Starter
Registered User
 
Join Date: Mar 2014
Posts: 9
Re: Oil light still comes on after replacing oil pressure sending unit.

Sorry forgot to mention it is the 2.0 and just a couple days ago I started hearing the rockers? Under the valve cover starting to tick. Maybe because oil not getting to them?

The head was completely rebuild about 1,000 miles ago if that makes a diffference .

The car has 174,000 miles and I am hoping it will make it to 250,000.
mash4077 is offline  
post #5 of 5 (permalink) Old 05-22-14, 04:11 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,916
Re: Oil light still comes on after replacing oil pressure sending unit.

You can get a repair guide with walkthrough at Autozone if you want to drop the sump / replace oil pump .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome