Problem with dash lights in a 1993 ford escort lx wagon 5speed 1.9L - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-29-2009, 17:15   #1 (permalink)
Registered User
 
Join Date: Sep 2009
Posts: 2
Question Problem with dash lights in a 1993 ford escort lx wagon 5speed 1.9L

Hello Forums!

I have a 1993 Ford Escort LX wagon with the 1.9L engine. When I first bought the car a few months ago I believe that the lights behind the dash (the ones that illuminate the speedometer, temp controls, and radio) worked. But now that its starting to get cold (and dark) earlier Ive knowledge now that they do not infarct work. I did some testing and figured it was the rheostat switch that controls the internal lights. So todat I went to a salvage yard and picked up 2 switches of the same type. So I plugged one in and...nothing. The only light that comes on is the one for the radio LCD back light. But when I take the switch out and put a wire in and cross the two connectors, the lights do come on, so its not anything to do with the lights. I tried the other switch and, still nothing. Is there something else I can check to try and make this work. I have to drive in to school in the morning and its pitch dark out so I ether have to drive with a wire hanging out of the plug for the switch or drive with the dome lights on.




Thanks!
Hunter Baker
hubaker is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-29-2009, 19:00   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,886
Re: Problem with dash lights in a 1993 ford escort lx wagon 5speed 1.9L

Are all the fuses good? The ones in that circuit are the Tail, room, and meter. Check all of them and make sure they are good.
Bert is offline   Reply With Quote
Old 10-02-2009, 17:47   #3 (permalink)
Registered User
 
Join Date: Sep 2009
Posts: 2
Question Re: Problem with dash lights in a 1993 ford escort lx wagon 5speed 1.9L

Hello and thanks for your reply,

Yes I did go through and check the fuses and they all seem to be in working order. The other thing is that, when you cross the wires it does cause the lights to come on, and I think if my logic is correct that if there was a fuse out, they wouldn't turn on at all, am I right? The only other clue I can give is that one of the rear reverse lights is out, but I think that may be a bulb more than anything. Thank you again so much for your replies!




Hunter Baker
hubaker is offline   Reply With Quote
Old 10-02-2009, 18:46   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,886
Re: Problem with dash lights in a 1993 ford escort lx wagon 5speed 1.9L

Here are 2 diagrams that show how it works. What wires are you connecting across? The power from the rheostat goes to a secondary junction block. It's located to the right of the steering wheel under the dash. Power comes from the switch through the L/brown and red wire to the inst/pnl fuse. See if there's power at that fuse with the switch on. From there it goes to the secondary junction block which sends power to the lights and another lb/red wire that goes to a relay to operate the LCD lights. See the second diagram.
Attached Images
File Type: jpg Lights1.jpg (90.8 KB, 24 views)
File Type: jpg Lights2.jpg (74.5 KB, 21 views)
Bert is offline   Reply With Quote
Old 10-22-2011, 05:40   #5 (permalink)
Registered User
 
Join Date: Oct 2011
Posts: 1
Re: Problem with dash lights in a 1993 ford escort lx wagon 5speed 1.9L

Hi there all,

i got the same problem on Ford Escort 1993, 1600cm3 and 16V.

I tried to disassemble the dashboard but i cant find nowhere to change the lights.

Anyone has schematics for this problem?

Thanks.
ristovski is offline   Reply With Quote
Old 10-22-2011, 18:33   #6 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,886
Re: Problem with dash lights in a 1993 ford escort lx wagon 5speed 1.9L

Check Autozone's web site for online repair manuals and diagrams.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:24.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.