Question on Escort fuel pump - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars

Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-27-05, 03:51 PM Thread Starter
Registered User
 
Join Date: Jan 2005
Posts: 2
Question on Escort fuel pump

How do I check to make sure fuel pump is working, and where is the pump located and how do I access it? Shut it off at night, next morning, won't start

PTBassMan is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-27-05, 03:55 PM Thread Starter
Registered User
 
Join Date: Jan 2005
Posts: 2
Re: Question on Escort fuel pump

Forgot to mention, this is a 1996 or 1997
PTBassMan is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
BA 6cyl Massive Fuel Consumption Problem julsisere Inline 6 Tech 12 12-12-06 05:48 PM
XF fuel pump relay T_Terror Inline 6 Tech 3 09-05-04 02:02 AM
where to find 88 V6 taurus fuel pump relay htran Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 5 05-30-04 05:27 PM
Ex-cab: Petrol still not working w/ new fuel pump Tragilgas General Tech 15 02-01-04 08:31 PM
fuel pump all pumped out barry_v General Tech 8 09-01-03 05:24 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome