Turn signal problem on Sierra - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri Forum for discussion of the Ford Laser, Ford TX3, Ford Escort, Ford Sierra and Mercury Capri.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-05-2007, 13:45   #1 (permalink)
Cyclist
 
Join Date: Jul 2007
Location: Sweden
Posts: 3
Turn signal problem on Sierra

Hi

I've just got a Ford Sierra V6 2,9i from 1989 and there's a problem with the turn signals. The hazard signal works fine but when I turn on the turn signals nothing happens. I've replaced the fuse but that didn't change anything.

I've heard from an unreliable source that the turn signal and the hazard signal runs on different relays and that a replacement of the turn signal relay might do the trick. Does that sound familiar? I'm a real beginner with cars but since I got this one I've decided that I'll try to learn - at least - some basics.

The thing with the relay - if that's the problem - is that I've left my manual at a friend's place kinda far from here (was reading some in it when I visited him) so I won't get it back in a while. I've taken a pic of the box with fuses and relays under the hood. I'd be reallt grateful if anyone could point out for me which relay is for the turn signal.



Thanks in advance!
Tillman
Tillman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-09-2007, 08:07   #2 (permalink)
Cyclist
 
Join Date: Jul 2007
Location: Sweden
Posts: 3
Re: Turn signal problem on Sierra

Hi again

I managed to get my hands on a manual and I will replace the relay and hope that this will solve the problem. What makes me uncertain is that the turn signals from time to time start to work again. Could the relay make the turn signals play?

Thanks in advance
Tillman is offline   Reply With Quote
Old 07-11-2007, 13:28   #3 (permalink)
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 688
Re: Turn signal problem on Sierra

Sorry mate couldn't help on this one, Sierra has been removed from Fords online database. :-(
Yes a faulty relay can certainly start to work when ever it feels like. See how it goes and report back.
Fordtech. is offline   Reply With Quote
Old 07-13-2007, 09:48   #4 (permalink)
Cyclist
 
Join Date: Jul 2007
Location: Sweden
Posts: 3
Re: Turn signal problem on Sierra

I decided to follow the cable that leads from the turn signal switch on the steering wheel to wherever it's connected, before I went to the store buying a new relay. And it turned out that there was a glitchy contact that was behind this problem. But now is it fixed =)
Tillman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:23.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.