2007 Montego "Wrench Light" - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego Forum for the discussion of the Ford Five Hundred, Mercury Montego, 2008+ models Ford Taurus and Mercury Sable.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-02-12, 06:00 AM Thread Starter
Registered User
 
Join Date: Oct 2007
Posts: 2
2007 Montego "Wrench Light"

What can cause this light to come on? I have 80,000 miles on it. It only seems to light up and cause a bucking hesitation when it rains. It doesn't do it when it is dry out. After googleing it, it sounds like a Electronic Throttle Body issue. If it was this, wouldn't it happen all the time not just when it rains. Please suggest what could be going wrong.

sefh is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-02-12, 08:29 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,339
Re: 2007 Montego "Wrench Light"

Autozone will pull codes for free. Post the results and we should be able to help.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome