Clicking noise when air is set to blow from floor vents... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego Forum for the discussion of the Ford Five Hundred, Mercury Montego, 2008+ models Ford Taurus and Mercury Sable.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-25-12, 09:26 PM Thread Starter
Registered User
 
Join Date: Jan 2012
Posts: 4
Clicking noise when air is set to blow from floor vents...

So, I have a slight problem; when I set the climate control to blow the air into the car from the floor vents, it makes a clicking sound as if the motor that controls airflow to different parts of the car is trying to move, but is either stuck, or is broken and cannot move. It is a faint noise, but I can definitely hear it.

However, every once in a while if I click the "defroster + floor vents" icon, the motor will be able to move the airflow vents to the correct positions so that some air will be blowing from the defroster and some will be blowing out of the floor vents. Now, this doesn't always work, but when it does, if I click on the normal icon for the floor vents so that ALL airflow is sent to the floor vents, the motor will be able to move to the correct position and the air will then blow from the floor vents only, as it should. Again, this doesn't always work.

Now, I am wondering how this can be fixed? Is it an easy fix that I can do at home in under an hour or two, or is it a somewhat complicated task that I should have the dealer look at/fix? Also, how much am I looking to spend on fixing this?

This isn't a huge issue for me at the moment, but it's slowly becoming very annoying.

Also, if it helps, I have a 2006 Ford 500 SEL AWD.

Thanks in advance for your answers!
bd7349 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome