dash problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego Forum for the discussion of the Ford Five Hundred, Mercury Montego, 2008+ models Ford Taurus and Mercury Sable.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-20-06, 06:28 AM
Unregistered
Guest
 
Posts: n/a
confused dash problems

we bought our new 2005 500 in november of 2005 now it's march 06 and we started having problems with the dash. the gages all drop to 0 and vibrate, then go back up again, the lights on the dash will go out. all of this with no warning so we took it into our dealership(krug ford lincoln mercury) they have had it a week and still dont know what is wrong with it. we also had a problem with the 1st cd changer so they replaced that. there were only 50 miles on it when we bought it so we are a little upset that we are having these problems and they dont whats wrong.

 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-18-06, 01:04 PM
Registered User
 
Join Date: Nov 2006
Posts: 5
Re: dash problems

Old post, I know... but it sounds like you have a short or loose cable somewhere in your electrical system. Have a dealer check all wiring harnesses that provide power to the dashboard.

Brandon
New Sales/Leasing and Used Sales
Clair Ford-Lincoln-Mercury-Mazda
Saco, ME 04073
InfamousG is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome