Instrument Cluster Removal Procedure - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego Forum for the discussion of the Ford Five Hundred, Mercury Montego, 2008+ models Ford Taurus and Mercury Sable.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-03-2014, 19:35   #1 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 352
Instrument Cluster Removal Procedure

We are seeing allot of these recently for burnt out light bulbs making the cluster very hard to see. I had another one so I made a quick video so you can take out the cluster without damaging the trim panels and change the bulbs or whatever you need to fix all yourself.

__________________
Check out all my Ford Tech Repair Videos @
http://www.youtube.com/user/FordTechMakuloco
Please Subscribe. Always something new and interesting!
makuloco2000 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-04-2014, 11:14   #2 (permalink)
Registered User
 
Join Date: Apr 2014
Posts: 4
Re: Instrument Cluster Removal Procedure

Hi, new to the forum.

i have a problem with my instrument cluster on my 2006 Ford Freestar....everything works except the screen that shows the odometer reading/trip reading etc...has blacked out. What should i start with to trouble shoot the problem....is it a fuse or relay that has blown? Is it due to a faulty speed sensor or has the instrument cluster crapped the bed. Thoughts?
Gecko77 is offline   Reply With Quote
Old 04-06-2014, 09:50   #3 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 352
Re: Instrument Cluster Removal Procedure

Quote:
Originally Posted by Gecko77 View Post
Hi, new to the forum.

i have a problem with my instrument cluster on my 2006 Ford Freestar....everything works except the screen that shows the odometer reading/trip reading etc...has blacked out. What should i start with to trouble shoot the problem....is it a fuse or relay that has blown? Is it due to a faulty speed sensor or has the instrument cluster crapped the bed. Thoughts?
No the cluster is done for that is a faulty part of the board itself usually a solder joint or multiple solder joints is it truly a freestar van or the Freestyle wagon? Just wondering cause I have never seen cluster issues on the freestars. But the exact same issue you are describing is very common on like the 98 f150 and you bang on the dash and the odometer works again those had the bad solder joint too.
__________________
Check out all my Ford Tech Repair Videos @
http://www.youtube.com/user/FordTechMakuloco
Please Subscribe. Always something new and interesting!
makuloco2000 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:47.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.