Problem with Taurus 2008 Limited message center - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego Forum for the discussion of the Ford Five Hundred, Mercury Montego, 2008+ models Ford Taurus and Mercury Sable.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-09-2009, 16:04   #1 (permalink)
wrc
Registered User
 
Join Date: Mar 2009
Posts: 3
Problem with Taurus 2008 Limited message center

I purchased a new Taurus 2008 Limited/Five Hundred new in the fall of 2007. Up until the end of last month I have had no problems at all. I started having problems with the message centre displaying lines of orange dashes when I turned on the ignition (happened twice so far). Lately the main message centre (digital) in the instrument cluster has been fading back and forth from bright to completely black. This has happened intermittently over the last two weeks and is occurring more frequently in the last few days. I have taken it in for warrenty service but am getting the run around, as the problem is intermittent and they say that they are not finding any diagnostic trouble code for the problem. Is there anyone having a similar problem?
Thanks, wrc
wrc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-10-2009, 08:12   #2 (permalink)
Registered User
 
Join Date: Mar 2009
Posts: 1
Re: Problem with Taurus 2008 Limited message center

I have the same issue, 2008 Taurus, same orange bars and then fading to nothing. Occasionally came back but now is gone.
$380 for the part and $200 for labor. Full Cluster.
Not under warrenty.
Wish it was a simple reset, but obviously a faulty design.
Have never loved my 08 taurus, now less than before, will likely trade in the very near future.
Any suggestions, I have attempted to buy american, but now???
steverino is offline   Reply With Quote
Old 03-10-2009, 09:31   #3 (permalink)
wrc
Registered User
 
Join Date: Mar 2009
Posts: 3
Re: Problem with Taurus 2008 Limited message center

Thanks. I am finding the service personnel that look at the 2008 Taurus have no idea how their own product operates. So far, every time I take it in for service they don't know the service schedule on the Taurus 2008 when it's in black and white in the owners manual they hand you and you have to get signed when you go in for service. When I took it into the dealer yesterday, the service tech was flipping light switches etc. which have nothing to do with the fact that you can't see the message centre. He was trying to tell me that the light sensor on the dash was dimming the instrument panel on bright days. He said that was normal...well from day one I've always been able to see the message centre clearly and I drive in all kinds of weather situations and until two weeks ago I didn't have any problems with anything. What kind of crap is that...you're supposed to be able to see the message centre all the time. I have had my running lights set to the auto position since the day I drove the car off the lot and now they want me to fool around with the light settings every time I have a problem with the display lighting. This is the second new Ford I've had trouble with since 2000. It seems that every time there is a warranty problem they give you the run around until the warranty expires, then they are all too willing to service the car. I was going to buy a BMW 745i before I bought this one...won't be making the same mistake next time.
wrc is offline   Reply With Quote
Old 03-10-2009, 15:53   #4 (permalink)
Moderator
 
Join Date: Nov 2008
Posts: 1,067
Re: Problem with Taurus 2008 Limited message center

Sounds like your service writers are trying to diagnose the problem before it gets to the
mechanics. A few of our's tried that to grease their own wheels. They got fired. most of
their diagnoses were wrong.
chipset is offline   Reply With Quote
Old 04-22-2009, 09:54   #5 (permalink)
wrc
Registered User
 
Join Date: Mar 2009
Posts: 3
Re: Problem with Taurus 2008 Limited message center

Instrument cluster replacement was finally authorized from Ford and was replaced under warranty earlier this month. Everything is working as it should be when I bought the car new.

thanks for your input,
Warren
wrc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Taurus 2008+| Mercury Sable 2008+ | Lincoln MKS | Ford Five Hundred | Mercury Montego



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:45.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.