90 Festiva Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Festiva | Mazda 121 Forum for the discussion of the Ford Festiva and Mazda 121

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-21-08, 06:23 PM Thread Starter
Registered User
 
Join Date: Apr 2008
Posts: 1
90 Festiva Problems

I have this old automatic transmission 90 Festiva that my daughter drives back and forth to college. Twice in the last 6 months the oil filter has "popped" or "blown" off. I have never heard of such a thing happening. I know something is wrong when there is oil all over the back end. Anyone know why this is happening?

Also, I need a distributor cap SEAL. I cannot find one anywhere. Ford says they no longer make them. The car does not start after a rainstorm, which is a pretty big problem. She goes to school, it rains, and she can't get home.
Any ideas on finding one of these? I ordered one from a festiva parts place online and never received it. The distributor cap is 6 months old.

festi is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-13-08, 10:24 AM
FESTIVA FREAK
 
mechanicaldj's Avatar
 
Join Date: Nov 2006
Location: frederick,md/washington,dc
Posts: 6
Re: 90 Festiva Problems

first of all , check to see if your oil filter threads are either stripped or have been damaged
next make sure you are using a high quality oil filter

and just replace the distributor with a high quality and name brand cap and rotor
and if there is oil in the cap, check the PCV valve to the left of the throttle body

need Aspire/Festiva help?
http://fordaspire.5.forumer.com/
need Festiva/Aspire performance?
http://www.festivamotorsport.com/
mechanicaldj is offline  
post #3 of 3 (permalink) Old 09-18-10, 08:46 PM
Registered User
 
Join Date: Jul 2009
Posts: 1
Garage
Re: 90 Festiva Problems

Quote:
Originally Posted by festi View Post
I have this old automatic transmission 90 Festiva that my daughter drives back and forth to college. Twice in the last 6 months the oil filter has "popped" or "blown" off. I have never heard of such a thing happening. I know something is wrong when there is oil all over the back end. Anyone know why this is happening?

Also, I need a distributor cap SEAL. I cannot find one anywhere. Ford says they no longer make them. The car does not start after a rainstorm, which is a pretty big problem. She goes to school, it rains, and she can't get home.
Any ideas on finding one of these? I ordered one from a festiva parts place online and never received it. The distributor cap is 6 months old.
There are usually quite a few Festivas at the local junkyards like Pic a part. I would try there. There are also people parting out Festivas on ebay periodically. I have found lots of parts that way.
davidgordon1 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Festiva | Mazda 121


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome