'95 WB Festiva engine problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Festiva | Mazda 121
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Festiva | Mazda 121 Forum for the discussion of the Ford Festiva and Mazda 121

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-26-2012, 19:55   #1 (permalink)
Registered User
 
Join Date: Oct 2012
Posts: 1
'95 WB Festiva engine problem

Hi all, my prob started about 2 weeks ago. I noticed when sitting at traffic lights the engine would idle normally but every now and then would hit a rough spot for a second then come good. At first when driving along it ran normally but the last two days its starting to get a bit chuggy when driving. Any ideas would be appreciated, thanks in advance.
daybreaklover is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-26-2012, 20:07   #2 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 3,185
Re: '95 WB Festiva engine problem

Try cleaning the MAF, IAC and throttle body
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 10-27-2012, 03:53   #3 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 9,068
Re: '95 WB Festiva engine problem

Also check plugs and wires , could be breaking down intermittently under load .
R.S.LOGAN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Festiva | Mazda 121



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:17.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.