ford festiva fiesco - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Festiva | Mazda 121 Forum for the discussion of the Ford Festiva and Mazda 121

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-08-07, 08:04 PM Thread Starter
Registered User
Join Date: Apr 2007
Posts: 1
confused ford festiva fiesco

can someone help me. I have 1990 festiva that won't start, is getting fuel up to the injectors, it has spark but it wont start. I think that the injectors are not opening but I dont know the cause for that, thanks Nelson
nelsonpe27 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-23-08, 05:37 PM
Registered User
Join Date: Jan 2008
Posts: 3
Re: ford festiva fiesco

1990 - '93 Festivas are notorious for this 'not starting' problem, but your post is a little contradictory. It's getting fuel to the injectors, but the injectors are 'not opening'???. Regardless, those of us with Festiva's in that year range ( I am one) are not getting 'spark'. That problem is one of three; coil, ignition module, or crank sensor (inside the distributor), most likely, the distributor. Are you SURE you're getting spark? If you're getting 'spark' and fuel, it has to ignite!
clev is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Festiva | Mazda 121
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome