altenator trouble? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-19-06, 10:03 AM Thread Starter
Registered User
Join Date: Mar 2006
Posts: 1
altenator trouble?

I took apart my 1986 F-350 with a 460 last Sept. to replace the timing cover gasket. Something happened that I couldn't finish working on it. Now I am able to continue the work, I can't remember how the bracket mounts to the block/water pump. And I can't find a diagram in CHilton's, Haynes, or anywhere. Does anyone have a diagram or a link to a diagram or anything that can help me? Anything would be great.
Arcticmud22 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-20-06, 02:03 AM
Registered User
Join Date: Jan 2002
Location: brisbane
Age: 49
Posts: 617
gregaust is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech > 429-460 Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome