Problem Starting - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-04-06, 09:26 PM Thread Starter
Registered User
 
Join Date: Aug 2006
Posts: 2
Problem Starting

I just recently bought a 66 mustang that had literally all the original parts in the engine... it was having trouble starting... wouldn't take a jump so i had the batter tested and re-charged and replaced the solenoid... now when i try to start it the radio and lights come on... but it just make a singe clicking noise... any suggestions? before i replaced and charged the battery it would try to crank over but nothing....

blueliquidstar is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-04-06, 09:49 PM Thread Starter
Registered User
 
Join Date: Aug 2006
Posts: 2
Thumbs up Re: Problem Starting

Any suggestions?? my e-mail is blueliquidstars@yahoo.com Thanks :-)
blueliquidstar is offline  
post #3 of 5 (permalink) Old 08-05-06, 02:45 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: Problem Starting

clean all connections thoroughly. Battery, solenoid,starter,and any grounds.
Also wire could be corroded under the insulation.
HTH
thefonz is offline  
post #4 of 5 (permalink) Old 08-05-06, 06:13 PM
Registered User
 
Join Date: Aug 2005
Posts: 330
Re: Problem Starting

As above said. All contacts need to be sanded clean.
northey is offline  
post #5 of 5 (permalink) Old 09-19-06, 03:33 PM
66 Mustang 351C
 
ClevelandRocks's Avatar
 
Join Date: Sep 2006
Location: Albany
Posts: 36
Re: Problem Starting

look for the bad ground somewhere. It's trying to find ground through your accessories. that's why the radio and lights and stuff come on when you crank it.

Sounds like you ought to go through the electrical system pretty good.

ain't skeert...
ClevelandRocks is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Classic Mustangs


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome