Taillights Working Oddly - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-16-10, 01:51 PM Thread Starter
Registered User
 
Join Date: Sep 2010
Posts: 1
Taillights Working Oddly

Hi all,

I recently just picked up a 64 Thunderbird, Tudor Hardtop. I have a small issue with the taillights... I'm sure it's not a terribly complicated issue... here's the symptoms:

If I turn the lights on, taillights work like normal. Left and right signals both work. Only the right brake light works. Only the right hazard light works. If the left turn signal is on, I don't have brake lights.

Any ideas?

JokerSixTNine is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-16-10, 01:58 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: Taillights Working Oddly

That sounds like you have a problem in the turn signal switch.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Classic Thunderbirds
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome