69 Ranchero problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-28-08, 05:07 PM Thread Starter
Registered User
 
freshdes's Avatar
 
Join Date: Sep 2007
Posts: 10
69 Ranchero problems

i bought a 69 Ranchero on Friday. still in decent shape.

has 315 Cleveland with C6 box in.

problem is this: when you turn ignition, the motor swings and wants to fire up and sometimes does, but doesn't idle or doesn't even fire up!

any thoughts or suggestions what cause might be?

thanx!
freshdes is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-29-08, 07:51 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,737
Re: 69 Ranchero problems

Any history on the car? Sounds like a carby problem.
thefonz is offline  
post #3 of 3 (permalink) Old 02-04-08, 05:43 AM Thread Starter
Registered User
 
freshdes's Avatar
 
Join Date: Sep 2007
Posts: 10
Re: 69 Ranchero problems

don't know exact history. bought it 2 weeks ago.

used to have 6 cylinder in, but previous owner bought it with V8 already installed. turning out to be a bit of a nightmare!
freshdes is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Classic Trucks
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome