71 ford highboy chugging - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-14-12, 10:35 PM Thread Starter
Registered User
Join Date: Aug 2012
Location: pleasant grove utah
Posts: 1
71 ford highboy chugging

so im having a issue with my truck, when it get up to temuture it starts chugging real bad and it runs and idles horrible. it has a 351 in it with a 4brrl edelbrock carb. i thought maybe fuel pump. not it changed it out, then i just rebuilt the carb and it still chugging only when it gets hot but has trouble starting even when its cool. what could that be??
peterson177 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 08-15-12, 07:23 PM
Dazed and Confused
CatSkinner's Avatar
Join Date: May 2012
Location: Upstate New York
Posts: 5,280
Re: 71 ford highboy chugging

How old are the plugs and wires?
CatSkinner is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Older Fords > Classic Fords > Classic Trucks
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome