acceleration loss help! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-18-2007, 23:54   #1 (permalink)
1991 falcon fairmount
 
Join Date: Jan 2007
Location: new zealand
Posts: 5
Question acceleration loss help!

I have an 1991 ford fairmount falcon, recently i guy said have u checked air filter. we took it out bang ed it on the ground heaps of old dust and flies came out .put it back in.bout a day later it stars lose in power ,still goes but its less responsive now takes more time to pick up pwer. mechican said it wont be the carb , looks like it has one but its centre point injection. any advice would be great
DO IT MY SELF is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-19-2007, 03:32   #2 (permalink)
Registered User
 
jas24zzk's Avatar
 
Join Date: Jul 2005
Location: Wandin, Vic
Age: 42
Posts: 827
Re: acceleration loss help!

Start with a NEW filter!
they should NEVER be cleaned unless they are designed for it..i.e K&N
once you disturb them like that, you normally make them worse.

He called a CFI car a carbied one....i would get a new mechanic! pronto!

Jas
jas24zzk is offline   Reply With Quote
Old 01-19-2007, 15:13   #3 (permalink)
1991 falcon fairmount
 
Join Date: Jan 2007
Location: new zealand
Posts: 5
confused Re: acceleration loss help!

Hi Jas
have changed the filter, its still the same got any more advice, fuel filter maybe
DO IT MY SELF is offline   Reply With Quote
Old 01-20-2007, 00:44   #4 (permalink)
1991 falcon fairmount
 
Join Date: Jan 2007
Location: new zealand
Posts: 5
Re: acceleration loss help!

Hey its fix its self .must have been muggy weather!
DO IT MY SELF is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:21.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.