arrgh another ea problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-01-2004, 03:55   #1 (permalink)
Registered User
 
90glfalcon's Avatar
 
Join Date: May 2004
Posts: 75
arrgh another ea problem

l8ly my ea's been goin to shit, auxilary belt comes off, clutch is a goner nd now ive got som sort of battery problem.

after about 30 mins of driving my car, if i park somwher and turn it off and then try to turn it on agen within the next 30 mins it wont fire.
makes slow awful attempts to fire which make it sound like battery.
but the stereo and all oter electrics work fine, stereo completely resets tho and lose all my stations/settings.

seems to be able to start agen if it gets cold again.

and will start again if given a decent push start.

wats goin on?? ne help greatly appreciated. i love my ea but all this stuff goin wrongs startn to drive me nuts.
__________________
1990 GL Falcon.
MANUAL.
2 1/2" Catback Exhaust.
BoUnCiNg on Chopped Springs.
15" Sub.
700 Watt Amp.
18" Rims comin soon
90glfalcon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-01-2004, 04:10   #2 (permalink)
wants a manual!
 
John_xr6's Avatar
 
Join Date: Oct 2003
Location: Melbourne
Age: 29
Posts: 1,461
Re: arrgh another ea problem

talk to initial D, hes always having problems with His EA.
__________________
1994 COBALT BLUE ED FAIRMONT GHIA
Next Mod - T5 Manual Conversion
Pics Here
John_xr6 is offline   Reply With Quote
Old 12-01-2004, 04:19   #3 (permalink)
Pimpin the chrome
 
InitialD's Avatar
 
Join Date: Aug 2004
Location: Melbourne
Age: 30
Posts: 771
Re: arrgh another ea problem

Ohh ive had that before, cant remember what it was. All the electrics restarted itself and the car wouldnt start. but when it was cold it was all fine. Think the starter was cooked and was surging the car? umm ill try to remember
__________________
1991 Ford Falcon EA 30th Anniversary

EF head | EF XR6 Cam |Pacemaker 3320(?) extractors | Hiflo cat
3:23 | Auto | XH Snorkle | Thermos | 2.5" Mandrel Exhaust
Full NC2 Sportsman Interior inc Dash & Electrics
Custom Clear Tailights and Garnish
Sprint kit | Moffat front bar (soon) | king lows
FTR Chrome Rims | Driving lights | Custom ED Mesh grill
Pioneer of the Clear ED tailights
InitialD is offline   Reply With Quote
Old 12-01-2004, 04:24   #4 (permalink)
Registered User
 
90glfalcon's Avatar
 
Join Date: May 2004
Posts: 75
Re: arrgh another ea problem

thnx yeh tht wud b great if u cud rememba wat u did to fix it
__________________
1990 GL Falcon.
MANUAL.
2 1/2" Catback Exhaust.
BoUnCiNg on Chopped Springs.
15" Sub.
700 Watt Amp.
18" Rims comin soon
90glfalcon is offline   Reply With Quote
Old 12-01-2004, 11:44   #5 (permalink)
Registered User
 
RadEA's Avatar
 
Join Date: Jul 2004
Location: Central Coast NSW
Age: 26
Posts: 32
Re: arrgh another ea problem

mate i've had this problem with my ED, and it turned out to be the battery terminals, which were only a little corroded, and had pink corrosion on them too. I know it sounds stupid, but i had the EXACT same symptoms and if it wouldnt start, i would hit the battery terminals as hard as possible with my fist, and it would start! So, take out your battery and file the terminals clean, its a start at least.

Gazza
RadEA is offline   Reply With Quote
Old 12-01-2004, 11:46   #6 (permalink)
Mad Redhead
 
Join Date: Jul 2004
Location: Blue Mountains NSW
Age: 43
Posts: 113
Re: arrgh another ea problem

Could I have that once again in English please? *Bindi walks to bathroom and flushes her OWN head at sounding like a school teacher*
I'm with InitialD, sounds more like a starter motor issue than a battery one. Especially if all the electricals are working fine.
__________________
Bindi

EA 88
Corolla 88
______________________________________________

The story of my life...
bindi is offline   Reply With Quote
Old 12-01-2004, 13:35   #7 (permalink)
Pimpin the chrome
 
InitialD's Avatar
 
Join Date: Aug 2004
Location: Melbourne
Age: 30
Posts: 771
Re: arrgh another ea problem

RadEA is right, that would be the other thing i would check. Clean the contacts first, then if it keeps doing it id check the wiring to the Starter and or the starter.

Hope this helped
__________________
1991 Ford Falcon EA 30th Anniversary

EF head | EF XR6 Cam |Pacemaker 3320(?) extractors | Hiflo cat
3:23 | Auto | XH Snorkle | Thermos | 2.5" Mandrel Exhaust
Full NC2 Sportsman Interior inc Dash & Electrics
Custom Clear Tailights and Garnish
Sprint kit | Moffat front bar (soon) | king lows
FTR Chrome Rims | Driving lights | Custom ED Mesh grill
Pioneer of the Clear ED tailights
InitialD is offline   Reply With Quote
Old 12-01-2004, 20:12   #8 (permalink)
Registered User
 
90glfalcon's Avatar
 
Join Date: May 2004
Posts: 75
Re: arrgh another ea problem

lol thanks bro, yeh was the terminals being too corroded, scraped them clean and good as gold!
__________________
1990 GL Falcon.
MANUAL.
2 1/2" Catback Exhaust.
BoUnCiNg on Chopped Springs.
15" Sub.
700 Watt Amp.
18" Rims comin soon
90glfalcon is offline   Reply With Quote
Old 12-01-2004, 23:28   #9 (permalink)
Who? Me?
 
EA_Bender's Avatar
 
Join Date: May 2004
Location: Brisbane
Age: 33
Posts: 135
Re: arrgh another ea problem

i had the same problem but that was after playing with my timing, it wouldnt start, i took it to an auto electrician, they moved the dizzy about half a mill and it starts first time every time now. that might be somethign to consider. the only thing it does now is when i plant my foot, it takes a second to realise and then kicks into action, that ones got me stumped

bender
__________________
1990 EA Fairmont, Lowered 50 mil, 17 x 7 Advanti "Flash" Mags running on Falken rubber, NGK Iridium Plugs
Proud TQE Operator
Comming soon: BBM Conversion
EA_Bender is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EA Diff EA Wagon Trans | Driveline 2 04-18-2004 04:21
starting problem with my ea mad_ea_spac General Tech 17 07-17-2003 02:23

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:16.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.