EA Possessed? please help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-23-2003, 06:43   #1 (permalink)
wybub
Guest
 
Posts: n/a
EA Possessed? please help

Hi,

Some advice greatly appreciated. Have an 89 EA 3.9CFI wagon with some odd problems.

If I let her just creep away from dead stop it will accelerate albeit slowly to around 40kph. At 12kph itll change to 2nd and at 22kph into top unti I reach 40kph................mmmmmmmmmmm ...........bit strange. It now also appears to be misfiring at idle (feels like a tq20cam as the body starts to rocknroll) and at times idle will go up and then go down, but out on the highway it runs great. Sometimes when I turn her off it will pre-ignite, other times it will not depending whether idle is high or low at the time I stop.

Checked all sensors via ecu and all seem to be working. Did a diag and got no permanent faults.

Engine was remanufactured about 20k ago, so compression and engine internals are fine.

Ok so I adjusted the timing for the hell of it and reset the base idle. No significant change. Noticed that leads were a bit dodgy and no4 plug a bit rich. Assumed that leads and plugs may have been contributing to the problem so changed all leads and plugs but this did not seem to make any real difference.

Any ideas truly appreciated this is drivin me nuts

Cheers

Glenn
  Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2003, 14:37   #2 (permalink)
Registered User
 
Join Date: Oct 2002
Location: Toowoomba Qld
Posts: 121
You're engine was remanufactured only 20k ago and your getting pre-ignition ocassionally?

I thought pre-ignition was due to deposits inside the combustion chamber? My old car (Camry with 216,000kms) used to do it often (especially when hot).

Nothing been left in the throttle body / intake manifold? (Some gunk, a spanner, or something?).

Damien
damienpw is offline   Reply With Quote
Old 02-23-2003, 15:24   #3 (permalink)
LET EM' RIPPP
 
Join Date: Mar 2002
Location: Melbourne
Posts: 1,819
I thought Pre Ignition was timing related.
Is the dizzy ok?
__________________
CAUTION: Slippery When BOOSTING!
Bass Crazy is offline   Reply With Quote
Old 02-23-2003, 18:44   #4 (permalink)
Registered User
 
Join Date: Feb 2003
Location: Cobram
Posts: 197
I have had this problem before, and it was the TPS. It was crook, but was not crook enough to log a fault code in the computer. I also had a CP injection system. It did the exact same thing and after i replaced it the car was geat ever since.
__________________
Drive it like you stole it.....
tickfordboy is offline   Reply With Quote
Old 02-26-2003, 03:52   #5 (permalink)
wybub
Guest
 
Posts: n/a
Many Thanks guys , the dizzy fine, I'll check out the tps
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EA to ED Falcon review Aussie Falcon The Pub 13 08-24-2004 20:35
XD monts same as EA engine monts ?a 351 into a EA will it go ? Falcon kid General Tech 31 06-21-2004 22:58
EA in Wheels' all-time top 10 Falcons. However... Troutman Suspension | Wheels&Tires | Brakes 36 02-22-2004 02:06
EA Possessed? please help wybub General Tech 1 02-23-2003 16:07
MASSIVE CLEAROUT! (Audio, alarms, EA parts) SPHELL Audio And Security 39 05-31-2002 17:17

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:36.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.