EBII S Climate control - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-09-2005, 05:04   #1 (permalink)
Registered User
 
Join Date: Dec 2004
Location: Riverstone, NSW
Age: 53
Posts: 50
EBII S Climate control

Hi all

I recently bought a 92 EBII S pack, mainly to pull apart for spares. But my wife decided it was too good for that and now drives it daily. Anyway, some of the things I discounted when buying it now need fixing. Fixed the missing at idle with new leads, cap, plugs & rotor. Now I need to get the interior bits sussed.

Anyway, the "climate control" isn't working right. The fan works, air con works, and the cold/heat slider works. However, the interior/exterior/other settings slider does not work, it is "stuck" on windscreen. I also think the inside/outside selector doesn't work either. Can anyone give me any ideas on where to start looking?

Thanks

Cheers
Bruce
Speedway is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-09-2005, 06:27   #2 (permalink)
Registered User
 
smally351's Avatar
 
Join Date: Oct 2004
Posts: 456
Re: EBII S Climate control

Sounds like a vacuum leak somewhere in the system. Check the hoses that enter the engine bay on the LHS
smally351 is offline   Reply With Quote
Old 09-09-2005, 07:12   #3 (permalink)
Registered User
 
RAVEN's Avatar
 
Join Date: Jun 2005
Location: Melbourne, Australia
Posts: 1,562
Lightbulb Re: EBII S Climate control

Quote:
Originally Posted by Speedway
Hi all

I recently bought a 92 EBII S pack, mainly to pull apart for spares. But my wife decided it was too good for that and now drives it daily. Anyway, some of the things I discounted when buying it now need fixing. Fixed the missing at idle with new leads, cap, plugs & rotor. Now I need to get the interior bits sussed.

Anyway, the "climate control" isn't working right. The fan works, air con works, and the cold/heat slider works. However, the interior/exterior/other settings slider does not work, it is "stuck" on windscreen. I also think the inside/outside selector doesn't work either. Can anyone give me any ideas on where to start looking?

Thanks

Cheers
Bruce
Hi hows it going,is ur climate control the manually operated one or the digital automatic type?To me it sounds like this part called the "blend door motor" which isnt an expensive part from a wreckers but you have to pull the whole dash out to get to it, if i was you i would go to an aircon joint and just ask them if they could find out what wrong and then fix it your self, cause most of what you pay for when getting heaters and climate control fixed is the labour pulling the dash out.
__________________
240rwkw slug.
RAVEN is offline   Reply With Quote
Old 09-09-2005, 07:37   #4 (permalink)
Registered User
 
Join Date: Dec 2004
Location: Riverstone, NSW
Age: 53
Posts: 50
Re: EBII S Climate control

Thanks for the replies

I'll check out the vacuum lines tomorrow. I pulled the unit out of the dash but it has a bizillion wires attached to it. Stupid me thought it was a cable operated one and the cable had come loose! The one in the EB looks like the one in my EA (on the outside that is) with sliders and such.

If it is the blend door then my wife will just have to put up with it blowing on the windscreen :) I don't feel like pulling the dash apart.

Cheers
Bruce
Speedway is offline   Reply With Quote
Old 09-09-2005, 08:07   #5 (permalink)
Registered User
 
RAVEN's Avatar
 
Join Date: Jun 2005
Location: Melbourne, Australia
Posts: 1,562
Re: EBII S Climate control

Quote:
Originally Posted by Speedway
Thanks for the replies

I'll check out the vacuum lines tomorrow. I pulled the unit out of the dash but it has a bizillion wires attached to it. Stupid me thought it was a cable operated one and the cable had come loose! The one in the EB looks like the one in my EA (on the outside that is) with sliders and such.

If it is the blend door then my wife will just have to put up with it blowing on the windscreen :) I don't feel like pulling the dash apart.

Cheers
Bruce
AT least it is stuck in demister mode cause you need that if you need to get a roadworthy.
__________________
240rwkw slug.
RAVEN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 18:21.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.