Fuel Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-05-05, 05:24 AM Thread Starter
I...DRIVE....FORD!!!
 
-jjM-'s Avatar
 
Join Date: May 2005
Location: Mooroolbark, Melb, Vic
Age: 28
Posts: 105
confused Fuel Problems

gday all

problem started when i noticed that my fuel gauge wasnt workin anymore, and didnt budge or move at all, so opened up the back and riped the fuel pump from the back, and noticed that the meter was spent, so replaced with the ED, checked to make sure it was a 4.0ltr and it was MPI, started her up, started fine, accept drove it around, and found out that i couldnt floor it anymore, and the more fuel it consumed the more hard it became to get fuel into the motor, so replaced the pump itself with the one orignialy in there, and still same problems, i listened under the hood and also reliseing the injectors are workin over time, tryin to pump alot more fuel into the motor

can anyone help me out here or tell me if i have done something wrong here please

cheers

-jjM- is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-05-05, 04:20 PM
Registered User
 
Join Date: Jul 2003
Posts: 74
Re: Fuel Problems

Quote:
Originally Posted by -jjM-
gday all

problem started when i noticed that my fuel gauge wasnt workin anymore, and didnt budge or move at all, so opened up the back and riped the fuel pump from the back, and noticed that the meter was spent, so replaced with the ED, checked to make sure it was a 4.0ltr and it was MPI, started her up, started fine, accept drove it around, and found out that i couldnt floor it anymore, and the more fuel it consumed the more hard it became to get fuel into the motor, so replaced the pump itself with the one orignialy in there, and still same problems, i listened under the hood and also reliseing the injectors are workin over time, tryin to pump alot more fuel into the motor

can anyone help me out here or tell me if i have done something wrong here please

cheers
Fuel filter blocked perhaps?
rod71 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome