My EA's Power Just Gone - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-02-2005, 06:49   #1 (permalink)
Registered User
 
Grechie's Avatar
 
Join Date: Sep 2004
Posts: 33
My EA's Power Just Gone

hey friends...i guess im in need of help, dont no wot ive done, i was driving round last weekend, my My ford EA 6 cynlinder 1989 model(EBGT Body Kit), it has 4499 Pacemaker Headers, Redback Exhuast 2 1/2 inch, etc, and a 3.9L with reco'd head on it....now all was sweet , it was running as fast as i liked, 9.5 to 100km/h etc, easy 200km/h top speed hit etc..(btw it was a dif CFI 3.9L with reco'd head dumped in..old CFI was stuffed)

Anyways i was booting it round, not knowing it was down 2 litres of oil, and the oil compression guage was down too, anyways, then near the end of the night, i put the foot down , and it was sluggish and stiff, it had slowed down, 1st gear was gutless compared to wot it used to do.. lost alot of power, also noticed when we stopped that the exhaust sounded quiter wen i revved it, alot quiter then wot it used to be, and wen i drive, its not how i like it, (droning)...:(

i took it home, gave it a rest, next day changed oil, and took it for a nice drive then put the foot down, same thing, sluggish, slow, timed it, 11 seconds to 100km/h compared to 9.5 :( it has defently lost power,....i use BP ultimate fuel if that helps ...,

(the old engine was burning oil, and was stuffed, so the headers were dirty and so was the zorst, but we didnt clean it wen we put new engine in, thort it would burn out eventually coz this CFI is healthier)
...

could there be a clog or plug up somewere, since the exhuast doesnt sound as loud anymore, and its slowed down, could there be a clogg or somethign in the exhuast system?? or is the engine stuffed? if possible ? i was constantly booting it then braking, etc ...why did all of a sudden in the night, it slowed down, and sounded quiter??

another thing that also crossed my mind possibly , is that, just recently now the altenator has carked it, causing engine to run off the battery...now could this be the events that lead up to this, a altenators dieing, even tho it hadnt actually burnt out just yet, could that be the reason why it decided to slow down, drainage of power then it 1 week later burnt out ??

what has happenend does anyone know??


-thanks for any comments :)
Grechie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-04-2005, 06:34   #2 (permalink)
Drugged Crash Test Dummy
 
Join Date: Oct 2003
Location: Clifton Springs, Victoria
Age: 30
Posts: 16
Re: My EA's Power Just Gone

hows it doing?
I just had a similar problem with my car not having any power. I found that the accellerator cable had stretched. therefore, full power was un obtainable.

a quick adjusting of the nut on the cable(Near the engine end) and it was back to its former glory.

hope this fixs it...
meanor is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:09.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.