Need Help With Ford Eb No Spark - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-18-2005, 23:42   #1 (permalink)
Registered User
 
Join Date: Aug 2005
Posts: 2
Need Help With Ford Eb No Spark

Hi there,
My partner was driving my EB ford when she stopped at the lights,
The car stalled without her even noticing until attempting to accelerate through the green light.
I had the car towed here and my uncle and myself found it had no spark,
We setup a LED light to the test plugs and checked for system faults.

My uncle had a ford manual with the codes,so we did the test the light seem to be doing what it is suppose to and flashed once pause and once again
being code 11 no system faults.

So we decided to make sure it was working disconnecting MAP sensor
and tried the test again ,it came up with code 22 MAP sensor fault,
so we tried a few others and all codes where flashing correctly.
The only thing that had us confused was the TFI Module when disconnecting
TFI plug and having all other connections plugged in correctly ,
The test would show no system faults code 11.

I thought it would show code 14 TFI module fault or worn distributor
I checked the dizzy cap and found that it was worn, the centre that sits on
the rotor was stuck in the cap and the round end was worn flat with little
craders in it, I replaced the cap and the coil still with no luck, it turns over
fine the fuel pump is pumping fine but no spark,We have checked all wiring
and tested which connections have power and it showed 12v to the coil plug
and also the TFI plug with ignition turned on.
Sorry about the long post but does anyone know if this would be faulty TFI?
Dave2005 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-19-2005, 02:34   #2 (permalink)
Registered User
 
Join Date: Aug 2004
Location: Newcastle
Posts: 89
Re: Need Help With Ford Eb No Spark

It could be the TFI.
I had a dodgy TFI that never showed up on an ECU error check.
WhiteOx is offline   Reply With Quote
Old 08-20-2005, 03:29   #3 (permalink)
Registered User
 
Join Date: Oct 2004
Location: Sydney (Blue Mountains)
Posts: 180
Re: Need Help With Ford Eb No Spark

I had a similar problem with an EA. I was able to start the car with the key but the moment I let it go it would stall. If I left the key in start it would run but the starter would always be engauged. It ended up being the TFI as a bad earth or dry heatsink paste ( on TFI/ distributer) can cause them to fail. I also would get the NO FAULT code. Hope this helps as the TFI is about $250. I did have spark when cranking!
BAWITHLOT is offline   Reply With Quote
Old 08-21-2005, 05:01   #4 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,880
Re: Need Help With Ford Eb No Spark

See http://www.therangerstation.com/tech...iagnostic.html and grab a multumeter to test the TFI module. If it's faulty I think the Bosch ones are around $90 at Veale's.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Old 08-21-2005, 05:18   #5 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,880
Re: Need Help With Ford Eb No Spark

Also try and chase the spark from the coil to the plugs. Test the coil by usind a noid light (cheap test lights use to test fuel injectors). Fit the noid light to the coil lead and see if it flashes when you turn the engine over. Then put and old spark plug with the gap opened slightly at the distributor end of the HT lead that comes from the coil and see if it flashes whhen you turn the engine over. Then do the same at the plug ends of the HT leadfs.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Old 08-21-2005, 05:22   #6 (permalink)
Registered User
 
Join Date: Mar 2005
Location: sydney
Posts: 889
Re: Need Help With Ford Eb No Spark

Quote:
Originally Posted by Dave2005
Hi there,
My partner was driving my EB ford when she stopped at the lights,
The car stalled without her even noticing until attempting to accelerate through the green light.
I had the car towed here and my uncle and myself found it had no spark,
We setup a LED light to the test plugs and checked for system faults.

My uncle had a ford manual with the codes,so we did the test the light seem to be doing what it is suppose to and flashed once pause and once again
being code 11 no system faults.

So we decided to make sure it was working disconnecting MAP sensor
and tried the test again ,it came up with code 22 MAP sensor fault,
so we tried a few others and all codes where flashing correctly.
The only thing that had us confused was the TFI Module when disconnecting
TFI plug and having all other connections plugged in correctly ,
The test would show no system faults code 11.

I thought it would show code 14 TFI module fault or worn distributor
I checked the dizzy cap and found that it was worn, the centre that sits on
the rotor was stuck in the cap and the round end was worn flat with little
craders in it, I replaced the cap and the coil still with no luck, it turns over
fine the fuel pump is pumping fine but no spark,We have checked all wiring
and tested which connections have power and it showed 12v to the coil plug
and also the TFI plug with ignition turned on.
Sorry about the long post but does anyone know if this would be faulty TFI?
replace the coil and distributor together they are both prone for failures i cant remember how many i have changed about 70% of the time it is module on side of dizzy but the dizzy is so cheap now complete inc cap & rotor your better off to replace as a complete unit as i have seen the pickup fail as well. trust me on changing coil as well as its cheaper than a towtruck in the near future. repco is always putting the dizzys in the trade leaflet as if they have 10000000 to many to burn
reece1 is offline   Reply With Quote
Old 08-29-2005, 04:46   #7 (permalink)
Registered User
 
Join Date: Aug 2005
Posts: 2
Re: Need Help With Ford Eb No Spark

thanks everyone for the info,I rang around and found the new parts
were quite cheap from Thompson Spare parts .
$55.00 for coil
$52.00 for TFI
and twenty somethin for dizzy cap and rotor,
Went ahead and installed everything and she fired first go!!
So I was #**#in cheerin.
thanks
Dave2005 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:02.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.