No oil pressure guage. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-06-05, 09:31 PM Thread Starter
Registered User
 
Join Date: Jan 2003
Location: Canberra region
Posts: 71
No oil pressure guage.

Hello all,
a couple of weeks ago I fitted an S/Fairmont/futura dash to my EBGli.

All worked perfectly until last night driving home i noticed the oil pressure guage was in the low red.

I started the car a couple of hours later expecting the oil pressure to have returned when the engine was warmed up but no it was now completely devoid of pressure.

I am sure that the car has plenty of pressure because the engine isn't rattling & I drove it to work this morning
(~30Km).

I pulled the wire off the sender & the guage goes flat out so the problem must be with the sender.

Are these senders prone to failure? If so is that how they fail typically?

Regards, Jim...

jim5_0 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-06-05, 10:59 PM
Registered User
 
Join Date: Apr 2003
Location: Northern NSW
Age: 61
Posts: 98
Re: No oil pressure guage.

Have your oil pressure checked with a master gauge just to be sure
Was it a new sender or an old one
If it was old and your oil pressure checks out ok then fit a new sender in anyway

BIGDOG
BIGDOG is offline  
post #3 of 3 (permalink) Old 05-24-05, 06:14 PM Thread Starter
Registered User
 
Join Date: Jan 2003
Location: Canberra region
Posts: 71
Re: No oil pressure guage.

Thanks BigDog. I pulled the sender out again & found that the small orifice feeding the sender itself was blocked with some stray teflon tape. Removed all tape & put it back in with gasket goo on the threads & all is working as it should.
jim5_0 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome