Something wrong with my EF Falcon - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-20-2005, 03:03   #1 (permalink)
Registered User
 
Join Date: Oct 2004
Location: Adelaide
Posts: 50
confused Something wrong with my EF Falcon

Hi everyone,

I was wondering if anyone could help me with this problem that I'm having with my car.

Today while driving my car I noticed that, as soon as it reached 60 km/h, the speedo needle dropped suddenly and then came back again. Few seconds later, the transmission suddenly downshifted to third gear and then shifted back to fourth again. This kept happening for the next half an hour and then went back to normal.

I suspect a faulty speed sensor but I'm not sure. I will take the car to a mechanic eventually, but I thought maybe someone here had a similar problem or might be able to point me in the right direction so that I can fix it myself.

Any help would be greatly appreciated.

Regards,
Alex
FlknTuff is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-20-2005, 07:03   #2 (permalink)
Registered User
 
jas24zzk's Avatar
 
Join Date: Jul 2005
Location: Wandin, Vic
Age: 41
Posts: 827
Re: Something wrong with my EF Falcon

G'day,
upon reading the first part of your post, i thought...in order... loose tranny cable, Speedo unit, speed sensor.

Then you mentioned, the odd behaviour of the trannny.

Start by checking ALL terminals on your battery. This area is critical! every terminal and connection here has to be SPOTLESS!

I once had my tranny go into limp mode (locked in third) problem was simply a dirty terminal at the battery.

Failing this, it still sounds like an electrical fault...see an auto elec

Cheers
Jas
jas24zzk is offline   Reply With Quote
Old 10-21-2005, 01:12   #3 (permalink)
Registered User
 
smally351's Avatar
 
Join Date: Oct 2004
Posts: 456
Re: Something wrong with my EF Falcon

Sounds like a faulty speedo transducer to me, or even the drive or driven gears for the transducer. When the PCM loses the speedo input signal it will go into limp mode and 3rd gear is all you will get with drive selected. A simple PCM fault code check will probably reveal a code relating to loss of vehicle speed input in the memory codes.
smally351 is offline   Reply With Quote
Old 10-21-2005, 01:38   #4 (permalink)
Registered User
 
Join Date: Oct 2004
Location: Adelaide
Posts: 50
Re: Something wrong with my EF Falcon

Quote:
Originally Posted by smally351
Sounds like a faulty speedo transducer to me, or even the drive or driven gears for the transducer. When the PCM loses the speedo input signal it will go into limp mode and 3rd gear is all you will get with drive selected. A simple PCM fault code check will probably reveal a code relating to loss of vehicle speed input in the memory codes.
Would you be able to tell me where the speedo transducer is located and how to do a PCM fault code check?
FlknTuff is offline   Reply With Quote
Old 10-21-2005, 09:14   #5 (permalink)
Registered User
 
smally351's Avatar
 
Join Date: Oct 2004
Posts: 456
Re: Something wrong with my EF Falcon

The transducer is bolted to the extension housing on the rear of the transmission RHS.
A scan tool is the best way to extracr codes, but Im sure there are ways of doing this with bridge wires and an LED test light, search the forum for threads on this.
smally351 is offline   Reply With Quote
Old 10-21-2005, 17:31   #6 (permalink)
Fed
Registered User
 
Join Date: Jan 2005
Posts: 23
Re: Something wrong with my EF Falcon

Economy mode converter lockup?
If the car is 'new' to you and your are not real bright (no offense intended), this could easily be mistaken for a gear change?
Fed is offline   Reply With Quote
Old 10-23-2005, 17:56   #7 (permalink)
300+rwkw DC LTD Member
 
LTDHO's Avatar
 
Join Date: Jul 2001
Location: Melbourne, Vic
Age: 39
Posts: 1,620
Re: Something wrong with my EF Falcon

My LTD did it once. It was only low on fluid.
__________________
LTDHO
Power by Herrod 185rwkw
Power by me 313.6rwkw
Stereo by ///Alpine
LTDHO is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:23.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.