Speedo sender - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-30-05, 11:34 PM Thread Starter
Registered User
 
Join Date: Jun 2005
Posts: 7
Speedo sender

hi
speedos not working in my eb xr6, i bought a new sender unit yesterday from Ford, do I need to lower extension housing to replace? Whats the best method? The sender is faulty, cos the computer isn't getting any readings either from the sender. Thanx...
ebiisxr6 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-01-05, 03:50 AM
Registered User
 
Join Date: Mar 2005
Location: sydney
Posts: 889
Re: Speedo sender

Quote:
Originally Posted by ebiisxr6
hi
speedos not working in my eb xr6, i bought a new sender unit yesterday from Ford, do I need to lower extension housing to replace? Whats the best method? The sender is faulty, cos the computer isn't getting any readings either from the sender. Thanx...
i have done some of these but cant quite remember i am sure you can do it in place. if not you just drop the mount,on a jack and you dont need to pull the t/shaft or anything like that
reece1 is offline  
post #3 of 3 (permalink) Old 07-03-05, 11:46 PM Thread Starter
Registered User
 
Join Date: Jun 2005
Posts: 7
Re: Speedo sender

Thanks, yeh its not the sender after all that, my multimeters giving me a reading of 0.6V to the sender, the Ford workshop manual says this should be 8.2V, so now a fault finding mission down the circuit!!
ebiisxr6 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > E-Series Falcons
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome