1989 Cougar - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-16-05, 01:01 PM
Thatgirl1971
Guest
 
Posts: n/a
1989 Cougar

Hi all,

My 1989 Cougar won't hold a charge. I bought a brand new battery, new
terminals, and it still won't hold a charge for more than a few hours.
Could it be the alternator? How can you tell?

TIA!



 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-16-05, 03:01 PM
johanb
Guest
 
Posts: n/a
Re: 1989 Cougar

Pull 1 of the terminals, put a amp meter in between terminal and post and
if it pulls more than 0.5 amps you have a problem.

You have to wait a couple of seconds and let interior lites go out before
getting a accurate reading


"Thatgirl1971" <Thatgirl1971@msn.com> wrote in message
news:1129490420.999332.316600@g14g2000cwa.googlegroups.com...
> Hi all,
>
> My 1989 Cougar won't hold a charge. I bought a brand new battery, new
> terminals, and it still won't hold a charge for more than a few hours.
> Could it be the alternator? How can you tell?
>
> TIA!
>
>



 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome