1992 Escort - electrical issues? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-14-2005, 19:01   #1 (permalink)
kendra
Guest
 
Posts: n/a
1992 Escort - electrical issues?

Hi :)

I just purchased a Ford Escort for $400...I fixed up the breaks but the
"park"/"running" lights don't work in the back. It's not a fuse. I also have
problems with the dash lights - if I signal right they go out...and I have
to wiggle them so they come back on. The left side the dash doesn't even
really light up (ie, the fuel and temp). I don't know if they're supposed
to, I haven't looked close at it all. I just wondered if it's a common
problem? I'm scared to let the mechanics go at 'er and charge me $300 in
lookie lou time.

Oh and this might also be related..I don't think the lighter works b/c I
used plug an CD car adapter into my old car and it won't work in this one.

Any help or ideas are very much appreciated. Thanks!!


  Reply With Quote
Sponsored Links
Advertisement
 
Old 03-15-2005, 17:01   #2 (permalink)
pickone@kato.com
Guest
 
Posts: n/a
Re: 1992 Escort - electrical issues?

On Tue, 15 Mar 2005 01:39:31 GMT, "kendra" <k18@shaw.ca> wrote:

>Hi :)
>
>I just purchased a Ford Escort for $400...I fixed up the breaks but the
>"park"/"running" lights don't work in the back. It's not a fuse. I also have
>problems with the dash lights - if I signal right they go out...and I have
>to wiggle them so they come back on. The left side the dash doesn't even
>really light up (ie, the fuel and temp). I don't know if they're supposed
>to, I haven't looked close at it all. I just wondered if it's a common
>problem? I'm scared to let the mechanics go at 'er and charge me $300 in
>lookie lou time.
>
>Oh and this might also be related..I don't think the lighter works b/c I
>used plug an CD car adapter into my old car and it won't work in this one.
>
>Any help or ideas are very much appreciated. Thanks!!
>


sell it
preferably the junk yard

hurc ast
  Reply With Quote
Old 03-15-2005, 19:01   #3 (permalink)
kendra
Guest
 
Posts: n/a
Re: 1992 Escort - electrical issues?

That's not helpful.


<pickone@kato.com> wrote in message
news:atte31plfvsk881ff99ec7ic5s9mh3er0q@4ax.com...
> On Tue, 15 Mar 2005 01:39:31 GMT, "kendra" <k18@shaw.ca> wrote:
>
>>Hi :)
>>
>>I just purchased a Ford Escort for $400...I fixed up the breaks but the
>>"park"/"running" lights don't work in the back. It's not a fuse. I also
>>have
>>problems with the dash lights - if I signal right they go out...and I have
>>to wiggle them so they come back on. The left side the dash doesn't even
>>really light up (ie, the fuel and temp). I don't know if they're supposed
>>to, I haven't looked close at it all. I just wondered if it's a common
>>problem? I'm scared to let the mechanics go at 'er and charge me $300 in
>>lookie lou time.
>>
>>Oh and this might also be related..I don't think the lighter works b/c I
>>used plug an CD car adapter into my old car and it won't work in this one.
>>
>>Any help or ideas are very much appreciated. Thanks!!
>>

>
> sell it
> preferably the junk yard
>
> hurc ast



  Reply With Quote
Old 03-15-2005, 19:01   #4 (permalink)
Tom Adkins
Guest
 
Posts: n/a
Re: 1992 Escort - electrical issues?



Lets see if I have this right:
1: No rear tail lamps
2: Right side Inst. Panel lamps go off when you signal Right.
3: Left side Inst. Panel lamps don't work at all
4: Lighter socket dead.

Is that correct? Do the Brake lights and front park lamps work? I'll assume yes
since you didn't mention them. Do the lights on the radio and heater controls come on?
It sounds like you checked the fuses. I think the 92 Escort had a fuse panel under the
hood also, take a look. Also, what do you "wiggle" when the lights go off on the inst.
panel?

Symptom 1: First check the bulbs (just replace them, they are old anyway and
inexpensive). While you are doing that look into the sockets, look for any corrosion
inside. Also look for loose wires in that area. If new bulbs don't fix it and there
are no obvious problems, you'll need to dig deeper.

Symptom 2and 3: This sounds like it could be a loose connector on the back of the
instrument cluster (the panel that contains the speedometer and gauges). The cluster
needs to come out to check this.

Symptom 4: Either a blown fuse, or defective lighter socket. If the previous owner
was a smoker the socket could be filled with debris and dirt causing a poor connection.

Hope this helps, Tom
  Reply With Quote
Old 03-15-2005, 20:01   #5 (permalink)
razz
Guest
 
Posts: n/a
Re: 1992 Escort - electrical issues?

This guys just an asshole
"kendra" <k18@shaw.ca> wrote in message
news:9GMZd.688412$Xk.493070@pd7tw3no...
> That's not helpful.
>
>
> <pickone@kato.com> wrote in message
> news:atte31plfvsk881ff99ec7ic5s9mh3er0q@4ax.com...
> > On Tue, 15 Mar 2005 01:39:31 GMT, "kendra" <k18@shaw.ca> wrote:
> >
> >>Hi :)
> >>
> >>I just purchased a Ford Escort for $400...I fixed up the breaks but the
> >>"park"/"running" lights don't work in the back. It's not a fuse. I also
> >>have
> >>problems with the dash lights - if I signal right they go out...and I

have
> >>to wiggle them so they come back on. The left side the dash doesn't even
> >>really light up (ie, the fuel and temp). I don't know if they're

supposed
> >>to, I haven't looked close at it all. I just wondered if it's a common
> >>problem? I'm scared to let the mechanics go at 'er and charge me $300 in
> >>lookie lou time.
> >>
> >>Oh and this might also be related..I don't think the lighter works b/c I
> >>used plug an CD car adapter into my old car and it won't work in this

one.
> >>
> >>Any help or ideas are very much appreciated. Thanks!!
> >>

> >
> > sell it
> > preferably the junk yard
> >
> > hurc ast

>
>
>



  Reply With Quote
Old 03-15-2005, 20:01   #6 (permalink)
pick one
Guest
 
Posts: n/a
Re: 1992 Escort - electrical issues?


"kendra" <k18@shaw.ca> wrote in message news:n1rZd.679991$Xk.250954@pd7tw3no...
> Hi :)
>
> I just purchased a Ford Escort for $400...I fixed up the breaks but the
> "park"/"running" lights don't work in the back. It's not a fuse.
> I also have problems with the dash lights - if I signal right they go
> out...and I have to wiggle them so they come back on. The left side the dash
> doesn't even really light up (ie, the fuel and temp). I don't know if they're
> supposed to, I haven't looked close at it all. I just wondered if it's a
> common problem? I'm scared to let the mechanics go at 'er and charge me $300
> in lookie lou time.
>
> Oh and this might also be related..I don't think the lighter works b/c I used
> plug an CD car adapter into my old car and it won't work in this one.
>
> Any help or ideas are very much appreciated. Thanks!!
>

First check to see if the recall for the fuel pump harness has been done ( your
local ford dealer can run OASIS for you ). The fuel pump harness goes under the
rear seat into the tank. The harness has been known to overheat due to a short
at the pump connections. The harness goes all the way to the dash area and will
cause all the problems you mention. You need too have someone who actually knows
what they are doing check out the car, it may not be the problem, but if it is
you can expect a really big bill because the only repair is the replacement of
the body harness and fuel pump.


  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical schematics ford escort 1994 1.3i p_cipri Interior | Electrical | ECU 1 02-06-2005 06:21
1996 Ford Escort LX - Serious Idling Issues 245driver Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 0 12-24-2004 04:59
1996 Escort LX - Serious idling issues 245driver Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 0 12-23-2004 09:43
Escort Accelerator Cable Issues eskort Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 2 12-16-2004 14:36
Arrrrghhhhh! laminge The Pub 79 04-11-2003 01:17

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:05.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.