1993 Crown Vic LX (Engine Rattles) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-08-2005, 10:01   #1 (permalink)
shawn78
Guest
 
Posts: n/a
1993 Crown Vic LX (Engine Rattles)

My Crown Vic (1993) LX

Last year the car began to run hot and overheated so when I took it to
the shop they dropped the transmission and needed to replace the
freeze plugs when they discovered that the block was cracked in the
center just where the transmission was removed. So they used some type
of bond cement which is heat tolerant made for autos. and put a freeze
plug in the dead center. Since then the car has never overheated. But
when you drive it after a while. The engine rattles. Can anyone
explain this.

Secondly there appears to be a rear seal leak which might explain why
my oil gauge after 3 days of adding 2 qts of oil drops whenever I come
to a stop. Moves erratically. Could the rear seal leak cause the
engine to lose oil pressure and cause the engine (valves) to rattle
based of the altering of the freeze plug assembly?

Get a new engine?

Any solutions? Please help and thanks in advance!!

--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
Topic URL: http://www.autoforumz.com/Ford-Mecur...ict111285.html
Visit Topic URL to contact author (reg. req'd). Report abuse: http://www.autoforumz.com/eform.php?p=522212
  Reply With Quote
Sponsored Links
Advertisement
 
Old 04-08-2005, 16:01   #2 (permalink)
lugnut
Guest
 
Posts: n/a
Re: 1993 Crown Vic LX (Engine Rattles)

On 8 Apr 2005 11:33:12 -0400, shawn78
<UseLinkToEmail@AutoForumz.com> wrote:

>My Crown Vic (1993) LX
>
>Last year the car began to run hot and overheated so when I took it to
>the shop they dropped the transmission and needed to replace the
>freeze plugs when they discovered that the block was cracked in the
>center just where the transmission was removed. So they used some type
>of bond cement which is heat tolerant made for autos. and put a freeze
>plug in the dead center. Since then the car has never overheated. But
>when you drive it after a while. The engine rattles. Can anyone
>explain this.
>
>Secondly there appears to be a rear seal leak which might explain why
>my oil gauge after 3 days of adding 2 qts of oil drops whenever I come
>to a stop. Moves erratically. Could the rear seal leak cause the
>engine to lose oil pressure and cause the engine (valves) to rattle
>based of the altering of the freeze plug assembly?
>
>Get a new engine?
>
>Any solutions? Please help and thanks in advance!!



If you are dropping oil pressure at idle enough to cause it
to rattle, it is time to be looking for another engine or
another vehicle.
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:32.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.