1993 mustang 5.0 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-10-2005, 13:02   #1 (permalink)
vaneck34
Guest
 
Posts: n/a
1993 mustang 5.0

I have a 1993 5.0 mustang. I just bought this car and have no history
on it. My problem is this. The car has some type on aftermarket cam
and doesn’t want to idle. I replaced the spark plugs because they were
fouled out ( covered with oil) After replacing the plugs the car would
start but still ran rough and after a few attenpts to do some repair
the plugs have fouled again. the engine has about 132,000 miles on it.
I ttok it to a repair shop and they recommended I try and put a stock
cam back in it. I was also told that the fuel pressure regulator may
be causing some of my erractic idle / fouled plug issues. The mechanic
that looked at it for me said that the timing was set correctly and
the compresion was also ok.

Please advise.

Troy

--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
Topic URL: http://www.autoforumz.com/Ford-Mecur...ict132700.html
Visit Topic URL to contact author (reg. req'd). Report abuse: http://www.autoforumz.com/eform.php?p=645348
  Reply With Quote
Sponsored Links
Advertisement
 
Old 08-10-2005, 21:01   #2 (permalink)
Backyard Mechanic
Guest
 
Posts: n/a
Re: 1993 mustang 5.0

vaneck34 <UseLinkToEmail@AutoForumz.com> wrote in news:1_645348
_badb74e70364c9c80be52b7be763e779@autoforumz.com:

> I have a 1993 5.0 mustang. I just bought this car and have no history
> on it. My problem is this. The car has some type on aftermarket cam
> and doesn’t want to idle. I replaced the spark plugs because they were
> fouled out ( covered with oil) After replacing the plugs the car would
> start but still ran rough and after a few attenpts to do some repair
> the plugs have fouled again. the engine has about 132,000 miles on it.
> I ttok it to a repair shop and they recommended I try and put a stock
> cam back in it. I was also told that the fuel pressure regulator may
> be causing some of my erractic idle / fouled plug issues. The mechanic
> that looked at it for me said that the timing was set correctly and
> the compresion was also ok.
>
> Please advise.
>
> Troy
>


I'd check the FPR{egulator} first.

Are you sure the plugs are oily or are they black and sooty? FPR will do
that.
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:17.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.