1996 Ford Taurus ???Electrical Problems???? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-14-05, 03:01 PM
minnesotagirl
Guest
 
Posts: n/a
1996 Ford Taurus ???Electrical Problems????

For a while now my car has been working strange. It starts fine, but
after you drive it for a while(3 miles or 50 miles) all of a sudden
the speedometer stops working and goes to zero and if you step on the
gas the RPMs rev up so high that you have to let up and very slowly
get up to speed. As soon as the speedometer stops so does the milage.
Also when that happens if I try to make a turn the power steering goes
out and I have to use all my strength to turn the wheel. Somebody
please help me out here!!!Thanks

--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
Topic URL: http://www.autoforumz.com/Ford-Mecur...ict138254.html
Visit Topic URL to contact author (reg. req'd). Report abuse: http://www.autoforumz.com/eform.php?p=669925


 
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-14-05, 05:01 PM
BOB URZ
Guest
 
Posts: n/a
Re: 1996 Ford Taurus ???Electrical Problems????



minnesotagirl wrote:

> For a while now my car has been working strange. It starts fine, but
> after you drive it for a while(3 miles or 50 miles) all of a sudden
> the speedometer stops working and goes to zero and if you step on the
> gas the RPMs rev up so high that you have to let up and very slowly
> get up to speed. As soon as the speedometer stops so does the milage.
> Also when that happens if I try to make a turn the power steering goes
> out and I have to use all my strength to turn the wheel. Somebody
> please help me out here!!!Thanks
>


For starters, i would check you battery connections and clean them.
Then check and clean all the under hood ground connections.
Especially block to firewall or unibody.

Bob


----== Posted via Newsfeeds.Com - Unlimited-Uncensored-Secure Usenet News==----
http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
----= East and West-Coast Server Farms - Total Privacy via Encryption =----
 
post #3 of 4 (permalink) Old 09-14-05, 05:01 PM
trainfan1
Guest
 
Posts: n/a
Re: 1996 Ford Taurus ???Electrical Problems????

minnesotagirl wrote:

> For a while now my car has been working strange. It starts fine, but
> after you drive it for a while(3 miles or 50 miles) all of a sudden
> the speedometer stops working and goes to zero and if you step on the
> gas the RPMs rev up so high that you have to let up and very slowly
> get up to speed. As soon as the speedometer stops so does the milage.
> Also when that happens if I try to make a turn the power steering goes
> out and I have to use all my strength to turn the wheel. Somebody
> please help me out here!!!Thanks
>


Vehicle Speed Sensor.

Rob
 
post #4 of 4 (permalink) Old 09-14-05, 07:01 PM
Michael
Guest
 
Posts: n/a
Re: 1996 Ford Taurus ???Electrical Problems????


"minnesotagirl" <UseLinkToEmail@AutoForumz.com> wrote in message
news:1_669925_d51517ae56768583a893bc44231379c4@autoforumz.com...
> For a while now my car has been working strange. It starts fine, but
> after you drive it for a while(3 miles or 50 miles) all of a sudden
> the speedometer stops working and goes to zero and if you step on the
> gas the RPM's rev up so high that you have to let up and very slowly
> get up to speed. As soon as the speedometer stops so does the milage.
> Also when that happens if I try to make a turn the power steering goes
> out and I have to use all my strength to turn the wheel. Somebody
> please help me out here!!!Thanks
>
> --

Similar thing happened to my 1997 Sable. Transmission range sensor needed
replacing. Ford PN for the Sable is F6DZ-7F293-A.

mike


 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome