1998 Ford Escort over rev at start - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-21-05, 02:01 AM
oulton.web@gmail.com
Guest
 
Posts: n/a
1998 Ford Escort over rev at start

Hi

I have a 1998 escort 1.6. When I start the car the engine revs to about
2500/3000 and will only drop to 750/1000 revs after a few minutes, when
the engine is warm, or if I repetedly turn the engine off and back on.
Can anybody offer any advice as to what the problem could be.

Thanks



 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-21-05, 05:01 AM
Backyard Mechanic
Guest
 
Posts: n/a
Re: 1998 Ford Escort over rev at start

oulton.web@gmail.com wrote in news:1119343048.482902.289920
@g44g2000cwa.googlegroups.com:

> Hi
>
> I have a 1998 escort 1.6. When I start the car the engine revs to about
> 2500/3000 and will only drop to 750/1000 revs after a few minutes, when
> the engine is warm, or if I repetedly turn the engine off and back on.
> Can anybody offer any advice as to what the problem could be.
>
> Thanks
>


Have the codes read out. Check engine lite?

Disconnect the MAF sensor connector and see if it will run ok... if it
doesnt, maybe it's the Throttle Position Sensor.

If it does run okay, clean the MAF.

Google for the how-to
 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome